Still Not Connecting to My Desktop

Hi everybody.

Today complete 3 months since I first try to connect my Neo4j Desktop instance to a local NestJS project, and it still fails. And I don't know why.

What I did:

  1. deleted and recreated the database in Desktop. Didn't work (connection to Neo4j Browser OK).
  2. reinstalled Neo4j Desktop from scratch, cleaning all files & configurations. Didn't work (connection to Neo4j Browser OK).
  3. Grabbed samples of NodeJS & NestJS from the Internet (mostly Github or Medium articles), reproduced the connections steps. Didn't work.
  4. created a sandbox instance and headed my connection to this instance. Worked.
  5. created a local docker container with an enterprise server. Worked.

So, today I made another attempt to connect to Neo4j Desktop - failure again. This is what I did few minutes ago.

First I try to connect to a fresh DB instance in Neo4j Desktop:

It fails! However, the instance is OK. These are the current settings:

Then I created a fresh Sandbox instance in the Sandbox and change my settings to connect to it:

The connection is established and the app runs just fine.

All I can tell is that I am very confused, lost, mad, frustrated. I cannot explain why only Desktop has this behavior. For now, I have no expectations to use Desktop despite I consider it a great tool for developers, it doesn't work for me (if I want to connect the local database to my app).


It may be a silly suggestion, but I've had trouble sometimes because of my anti-virus and firewall software, but I couldn't connect to a server instance, but could to Desktop. Have you tried turning them off?

1 Like

Hi @renatospaka,

Port 7474 is only used for hosting HTTP for either loading the Neo4j Browser app, or sending REST. The Neo4j drivers use the "Bolt" port, which by default is 7687.

Try the using port 7687 in your .env to see if that helps.


Today I'm resuming this issue and you gave me a great idea. I'll turn off Kaspersky and see what happens.

Hi @abk
That day I tried both ports with similar results: none got connected. But reported only one of them - sorry.

Someone sent me a clue about an issue involving access to Neo4j Desktop vs WSL2 via the localhost. I will investigate this.


Naive question: Can you connect to Neo4J URL (with a port number) using a regular browser? If that doesn't work, then I presume the issue has nothing to do with JavaScript.

Yes, @clem, I can connect my local Neo4j database to Neo4j Browser in Chrome or Edge smoothly, nice and easy. The next thing I will investigate is to turn Kaspersky AV off and try to connect to the local database.

Javascript issue was eliminated as soon as I managed to connect to a sandbox instance.