Neo4j Desktop 1.1.9 BoltConnectionError

I've caught a glimpse on the update notes while performing the update to 1.1.9, saying that it fixes bolt connection.
But, whereas previously, in 1.1.8, i was not experiencing any issue, now, in 1.1.9, the Desktop disconnects quite often (happened at least 10 times yesterday).
Issue is that it doesn't give an direct warning, and it's actually funny, as you can still write minimal queries and it will return an answer, but for long running queries, it looks like executing for a long period of time, but instead the connection has been lost in the meantime (what i've done is to fire a minimal query, like match(n) return count(n), it worked, then fired a long-running match, they, while it was running (looked like running) i fired the minimal again - and i got an "BoltConnectionError: No connection found, did you connect to Neo4j?")
When stopping the query (and the query was indeed stopped, as i've checked process manager and the cpu was idle), i used :server connect and it said "connected", but immediately , when i tried to run the long running query, i again got "BoltConnectionError: No connection found, did you connect to Neo4j?" whereas it was telling me, previously, that it was connected.
Nothing else but restart helps.

Do you have the same issue when you open Neo4j Browser, e.g. in Chrome? and run the queries there?

Do you think you can reproduce it? e.g. with a sample database?
Which Neo4j version are you using?

If the problem persists it's probably best to raise a GH issue with the steps to reproduce if possible.

Neo4j 3.4.1, but, even if i used Chrome after having this issue in the Browser, i did not pay attention if on Chrome i still had the same issue.
Trying to reproduce it with a fixed scenario, i'll update.

2018-09-06 12:30:03.939+0000 ERROR Unexpected error detected in bolt session '005056fffec00001-00001b60-00000070-3e8680a76265649d-efe39534'. The client is unauthorized due to authentication failure.
org.neo4j.bolt.v1.runtime.BoltConnectionFatality: The client is unauthorized due to authentication failure.
at org.neo4j.bolt.v1.runtime.BoltStateMachine.handleFailure(
at org.neo4j.bolt.v1.runtime.BoltStateMachine.handleFailure(
at org.neo4j.bolt.v1.runtime.BoltStateMachine.access$500(
at org.neo4j.bolt.v1.runtime.BoltStateMachine$State$1.init(
at org.neo4j.bolt.v1.runtime.BoltStateMachine.init(
at org.neo4j.bolt.v1.messaging.BoltMessageRouter.lambda$onInit$0(
at org.neo4j.bolt.runtime.MetricsReportingBoltConnection.lambda$enqueue$0(
at org.neo4j.bolt.runtime.DefaultBoltConnection.processNextBatch(
at org.neo4j.bolt.runtime.MetricsReportingBoltConnection.processNextBatch(
at org.neo4j.bolt.runtime.DefaultBoltConnection.processNextBatch(
at org.neo4j.bolt.runtime.ExecutorBoltScheduler.executeBatch(
at org.neo4j.bolt.runtime.ExecutorBoltScheduler.lambda$scheduleBatchOrHandleError$2(
at java.util.concurrent.CompletableFuture$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Exception in thread "neo4j.Scheduler-1"

Can you try to update the password in desktop on the right there is an administration tab.