How to show schema in Neo4j Bloom tool?

I am trying to run call db.schema.visualization() in Neo4j Bloom tool to visualise the schema but it is showing this error.

but in Neo4j browser it works. So what could be the possible alternate query to see the graph schema in Bloom tool.

Hello @spsingh559 !
There is a workaround:

  1. Create a Search phrase from the Perspective drawer
  2. Add this as the Cypher:
    CALL db.schema.visualization() YIELD nodes, relationships
    UNWIND nodes as node
    with node, relationships
    WHERE apoc.node.labels(node) <> ["Bloom_Perspective"]
    RETURN collect(node) AS nodes, relationships
    Then call the Search phrase from the search bar! :slight_smile:

Make sure that you have APOC installed


Thanks @sebastian.wictorin i have tried it but seems there is issue.

But still the same issue.

Is the problem with Neo4j 4.0.3 enterprise edition?

Hmm. The Search phrase using Neo4j 4.0.3 Enterprise edition works for me. We'll investigate!

@sebastian.wictorin apologies, actually i had the two same search phrase having different queries. Once I delete the old query and replace with one you suggested, it works !!