Connecting to local neo4j on mac from a windows virtual machine

I have neo4j 4.1.3 Enterprise edition installed on my macOS. Recently I installed a windows virtual image using VMWareFusion. The task I'm trying to achieve is to connect to my local neo4j from the windows image. I was able to connect to my local host from the windows testing some random services. However, I couldn't connect to neo4j. The steps I have tried to establish this connection is as follow:

1- Ensure that my virtual machine setting are configured correctly

Screen Shot 2021-05-16 at 12.07.32 AM

2- get my mac ip address using CLI : ifconfig and choose the IP address in en0

3- to test that the local address is reachable from the virtual image I created an http server using : python3 -m http.server 8123
4- from the virtual image I accessed 8123 using mac ip address as in http://<mac-ip>:8123 and that was accessible
Now to access neo4j I changed the following in neo4j configuration dbms.default_listen_address=< mac-ip>


and then tried to access http://<mac-ip>:7474/browser/ from the virtual image and got that the site can't be reached :ERR_CONNECTION_TIMED_OUT

I tried as well to add that ip address to the

dbms.connector.http.listen_address=< mac-ip>:7474
dbms.connector.http.advertised_address=< mac-ip>:7474

and that prevented neo4j from starting . Any tips to resolve this issue is hight appreciated. I spent a lot of time trying to figure it out but couldn't


By default neo4j only listens to local connections. You windows vm is another machine for neo4j, so you have to set the following to let Neo4j listen to all the network interfaces:

In the settings (neo4j.conf) uncomment the line with 'dbms.default_listen_address' to listen to all network interfaces.

# Network connector configuration

# With default configuration Neo4j only accepts local connections.
# To accept non-local connections, uncomment this line:


Thanks a lot for your reply, I have tried that and I got the response below

@raghad.baiad localhost:7474 is asking to connect to a instance of Neo4j running on the same machine where your Chrome, or equivalent, browser is running. If you change localhost to he ip address where Neo4j is running any sucesss?

1 Like

yes my mistake it is working perfectly now. Thanks a lot