Can't find Cypher

OK, just getting started, trying to import my data to the desktop version. Great info on here How-To: Import CSV Data with Neo4j Desktop - Developer Guides but once I get to the Load CSV section the screenshots change to something with a black background and talk about something called Cypher??? I went into terminal, usr/local/bin doesn't have any thing called Cypher.

Really struggling - I have created 4 csv files - one with my nodes, one with the nodes headers, one with the relationships and one will the relationship headers. Now I just want to see a graph. Just a simple graph with nodes and lines between the nodes. Any help appreciated.

the LOAD CSV statements can be run from either command line bin/cypher-shell of from Neo4j Desktop if you [Start] a graph and then [Open Browser] you can then submit the Cypher statements directly in the browser.

Think I tried that but it is asking for a username and password - I don't know what it wants, I tried the two email addresses that I used when downloading the tool, see attached.

Any help appreciated.


Neo4j ships with a default user neo4j and the default password is the same. However when installing/creating a new graph you should be prompted to enter a new password. In the end authentication details are recorded in data/dbms/auth and this is a plain text file, though the password is encrypted. If you do not recall the password at time of install, simply stop the running database, delete the file and restart. Also after restart and successful authentication you will want to change the password via Cypher statement `call'mynewPassword'); replacing 'mynewPassword' with a value of your choosing

I removed data/dbms/auth and then tried bin/cypher-shell, asking for username and password (it never asked me to create a password, btw), tried username neo4j and password neo4j and also the password that I used when I did the download, still no luck.

Isn't there someone who can help? Someone I can talk to? Even someone I can pay - I really, really need to get this working, have been struggling for 3 days now.

so as not to be blocked by auth one of other option is to modify conf/neo4j.conf and set

Note you will want to make sure this line is not already defined previously or if it is simply remove the old definition for this said parameter. After making this change, please restart Neo4j. you should no longer be prompted for username/password