Where can I find version 1.7 of the python neo4j driver (CANT upgrade beyond neo4j 3.5.x)

I can't use NEO4J 4.x becasue the site is using very old JAVA.
I used to work with the python neo4j driver
"import neo4j.v1"
I need to do an offline install (The site is not connected to the General web).
Any idea where can i Download it from?

shalom Elkin

Hello @shalom.elkin and welcome to the Neo4j community :slight_smile:

You can find all information here:


Hello, Maxime (or shall I call you COBRA?)
I visited this page many times - coming from different links. It does NOT_ Have a download location. Which is what I need.
Any idea where can i find it?

Shalom Elkin

I fine with both :slight_smile:

You can install it thanks to a command line:

Here is the git:


Cobra ! (that sounds more intimidating)

Thanks for answering so quickly. Point is, the first option will install the CURRENT driver, which is version 4.1.1 - I can't use it, as it is for NEO4J 4, which uses a (relatively) new JAVA, which I cant use. I have to use NEO4J 3.5.5 .
AND it works by downloading on a computer connected to the network.
The second suggestion is even worse - it is a pre-release, even newer.

Sorry to be a PITA (Pain in the A...) - I need to be able to download the version 1.7 of the driver, so that I can carry it on a USB drive to a machine WITHOUT outside connections. This will probably be a pythom wheel , and NOT the current one.

Shalom Elkin

No problem :slight_smile:

You should be able to specify the version: pip install neo4j==1.7

The source code for this version is here:


This did it! I downloaded the source, built it on my local machine, tested it.
Now It'll go to the enterprise machine, where I'll have to request someone with authority (Ahem !!!) to install it for me.

Thanks a lot ! Problem solved !

Shalom Elkin

1 Like

Hello, Cobra
5 weeks elapsed. I won't say I spent them all trying to install neo4j python driver - these are, despite the COVID, Jewish high holidays.
I can't install in the office.
Tried the neo4j-python-driver-1.7.6 : got screams about bolt.
[each iteration means : download on home computer, put it on google drive in a share Operation people in the office can access, beg them to pass the file through their cleansing process and copy to a dev machine in the office. 2-3 days per 23 Kb file].
installed neobolt-1.7.17 : got screams about neotime
installed neotime.1.7 : Ok!
went back- did neobolt
went back-did python driver
opened python (3.6)
import neo4j [DOES NOT COMPLAIN]
from neo4j import GraphDatabase
got message "cannot import name GraphDatabase".

dir() does not reveal any relevant component.

This is MAD. I figure I need to build a wheel for the neo4j-python-driver-1.7.6 which includes all requirements and all necessary packages, cleanse it as ONE file, and proceed.
How can I build it? I have the sources you pointed me at, and have to "invent the wheel"...
Help will be appreciated!


Shalom Elkin
I s r a e l

Hello @shalom.elkin :slight_smile:

I don't understand what you are trying to do :confused:
I never did this.


Hello, Maxime

I found a workaround. Nevertheless, you deserve an explanation.
I did some very useful stuff with Neo4j 3.5.x ,several years ago.
I wanted to resume it, using Neo4j 4.x
The application code is in python . For Neo4j 4, the driver requires Java 11.
Our current Java is 8, no plans for upgrade soon.
Solution: use Neo4j 3.5.x. but then you need driver 1.7.1
Which needs....

Workaround: I'll install Java 11 side by side with Java 8. When I need to run my programs, a simple change of JAVA_HOME will let me run "current" software.
No more archeology.

Thanks !
Shalom Elkin