Weird behavior after Desktop upgrade (DBMS failed to start: Error: Relate DBMS with tag... not found.)

I run Neo4j Desktop on a Windows Server. My databases are mostly of older version (4.02), however I have cloned them and upgraded some to (4.011).

In any case, today I stupidly allowed the Neo4j Desktop to upgrade itself.

Now I can no longer start most of my databases.

I am getting the following error:
DBMS failed to start: Error: Relate DBMS with tag neo4j-desktop-dbms-database-8976d6db-290a-4305-98f1-bb452cbbf01f not found.
The following logs and troubleshooting guide may help you diagnose the issue:* Desktop logs

  • Neo4j DBMS logs
  • Troubleshooting guide

The log shows

[2021-07-16 14:26:36.468] [info]  Starting Neo4j
[2021-07-16 14:26:36.469] [info]  Starting DBMS [database-dc14ec9a-61a1-40ed-8e54-37dda596f8e6] 'v4.0.11'
[2021-07-16 14:26:36.471] [warn]  Failed to get DBMS path through Relate Error: Relate DBMS with tag neo4j-desktop-dbms-database-dc14ec9a-61a1-40ed-8e54-37dda596f8e6 not found
    at D:\Neo4j\resources\app.asar\dist\
    at Maybe.getOrElse (D:\Neo4j\resources\app.asar\node_modules\@relate\types\dist\monads\monad.js:102:46)
    at Maybe.getOrElse (D:\Neo4j\resources\app.asar\node_modules\@relate\types\dist\monads\primitive\maybe.monad.js:93:22)
    at Object.P (D:\Neo4j\resources\app.asar\dist\
    at async Object.t.neo4jPath (D:\Neo4j\resources\app.asar\dist\
    at async Object.t.neo4jConfFolderPath (D:\Neo4j\resources\app.asar\dist\
    at async Object.t.neo4jConfPath (D:\Neo4j\resources\app.asar\dist\
    at async Object.t.start (D:\Neo4j\resources\app.asar\dist\
    at async Object.V [as start] (D:\Neo4j\resources\app.asar\dist\

This error obtains both for an original database, for its clones (on which I work in order to protect the data) and across different updates (4.02, the original one, to 4.011)

The database worked just fine before the upgrade. It is still present in the file system

Further interesting things:

  • Some databases that are mostly empty still work. This includes one on a new version of Neo4j (4.2+) and one on the same version that the originals work (4.02)

  • I guess these were never cloned? May that is the issue?

  • Neo4j Desktop also crashes when I close it.

  • Neo4j Desktop says that the databases in question are no longer supported:

Unsupported version
**Neo4j 4.0.11** is unfortunately not supported by Desktop since 1.3.4. To use it with Desktop again you need to manually upgrade, please follow the upgrade instructions.

However, the databases on 4.02 that run do no show this error.

A downgrade on Neo4j desktop 1.3.4 allows me to start the databases again.