Unexpected result with apoc.meta.relTypeProperties

CALL apoc.meta.relTypeProperties({rels: ["MEMBRE_DE"]}) returns no result even if call db.schema.relTypeProperties() return propertynames for "MEMBRE_DE" Relationship type

Do you have any idea why apoc.meta.relTypeProperties() and db.schema.relTypeProperties() returns different results ?

Doas anybody have an idea why apoc.meta.relTypeProperties() and db.schema.relTypeProperties() provide different results ?

Hello @o.boussekey :slight_smile:

Did you try the function without specifying anything in the config parameter? Can you try:

CALL apoc.meta.relTypeProperties({includeRels: ["MEMBRE_DE"]})

Can you also show us the result of db.schema.relTypeProperties()?


Hello Cobra, here are the results of the 2 calls :

Hello @o.boussekey :slight_smile:

It's because you added `` to your labels and relationship types so this query should work:

CALL apoc.meta.relTypeProperties({includeRels: ["`MEMBRE_DE`"]})


Hello Cobra,
Thanks a lot for your help. I've tried but unfortunatelyy, I have the same result : nothing :

Any other idea ?

Can you take a screenshot of the left panel where I can see labels and relationship types please.

That's weird...


CALL apoc.meta.relTypeProperties({includeRels: [":`MEMBRE_DE`"]})

Same result :

Which version of Neo4j do you have and which version of APOC do you use?

I'm using Neo4j 4.2.0 (Aura Free) and APOC 4.3.0-rc01

Can you try to upgrade the version of Neo4j?

Hello Cobra,
Unfortunately, I can't upgrade the version because it's running on Neo4J Aura.
I have the same results with a Neo4j desktop install (version 4.2.4)

I took a look at the documentation and normally it should work based on what I see on the screenshots:

CALL apoc.meta.relTypeProperties({rels: ["MEMBRE_DE"]});

If not, you have to raise an issue on Github.


Thx a lot for your help Cobra, I'll raise an issue on Github.
have a nice day