Uncompatibility of Neo4j 4.0.0 with Java 8

On my system with Ubuntu 18.04 and Java 8 (Oracle 1.8.0_191) and with Maven (3.6.0), when I compile (mvn install) a simple project with only one dependency org.neo4j:neo4j:4.0.0, the build succeeds but target/classes is empty (which should include the .class files). I tried two different Maven versions (also 3.6.3) but no success. Also, I tried two different Java 8 versions (also 1.8.0_241) but no success.
The problems seems to be only in Linux and on Java 8 and for Neo4j 4.0.0. In Ubuntu with Java 12 and in Windows it created the .class files. Also, for Neo4j versions prior to 4.0.0 it was successful.

1 Like

Yes, Neo4j 4.0+ is compatible with Java 11 only.

Java 8 is already end of life.

1 Like

ohh, thats sad, my current project has the Java-8. Need to see if we have any backward compatibility.
Any plan Michael?

System requirements - Operations Manual list the requirements for Java

Are you using Neo4j embedded?

Yes.....................! (Dots added because the page says: Post must be at least 20 characters)