Unable to find any JVMs matching version "11"

Unable to find any JVMs matching version "11" running console after installation of mac community server

1 Like

More details would better help us help you.


I ran into the same issue after running brew upgrade.
For me the solution was to install official JDK 11, not brew's openjdk. No matter what I tried, I couldn't get neoj4 to recognize that I have openjdk@11 via brew installed.


To see which versions of jdk you have installed, try running

ls -la /Library/Java/JavaVirtualMachines/

you should see something like

 ls -la /Library/Java/JavaVirtualMachines/                                                                      2126ms  Thu Jul  9 18:30:19 2020
total 0
drwxr-xr-x  5 root  wheel  160 Jul  9 18:30 ./
drwxr-xr-x  5 root  wheel  160 Jun  1 14:34 ../
drwxr-xr-x  3 root  wheel   96 Jul  9 18:29 jdk-11.0.7.jdk/
drwxr-xr-x  3 root  wheel   96 Jul  9 18:30 jdk-14.0.1.jdk/
drwxr-xr-x  3 root  wheel   96 Oct  1  2018 jdk1.8.0_181.jdk/
1 Like

Installing OpenJDK 11 resolved the issue for me. I'm running version 4.1.3 of neo4j.

openjdk version "11.0.8" 2020-07-14
OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.8+10)
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 11.0.8+10, mixed mode)

Installing OpenJDK 11 resolved this for me as well. I'm running the 4.0.8 community edition of Neo4j.

brew install openjdk@11

And then symlink:

sudo ln -sfn /usr/local/opt/openjdk@11/libexec/openjdk.jdk /Library/Java/JavaVirtualMachines/openjdk-11.jdk

I faced the same issue. I fixed it by setting up JAVA_HOME and Adding JAVA path in the path variable. I added these in bash_profile, spinned new terminal and it worked perfectly. Hope this helps.