Trying to get started - Database failed to start

Hello everyone,

I was trying to get started with Neo4j Desktop and start a DB, but I was greeted with an "Initialization Error" when I first opened it and also with the following message:

Database failed to start: Database process terminated, see logs.. Check the logs

I'm on Windows 7 using Neo4j Desktop 1.3.11 and already tried to start a database as an admin which resulted in the "Database failed to start [...]" message again. Moreover, this popped up:

Conflicts occurred

Database Movie Database can not be started due to conflicts with external processes.

To fix this problem, let us change these port configurations:

  • bolt : 11005 → 11004
  • http : 11006 → 11007

"Fix configurations" button did not resolve the issue.

I tried reinstalling multiple times on 2 different computers now (both Windows 7).

Navigating from within Neo4j Desktop to Developer -> View logs leads to an empty folder.
From log from .Neo4jDesktop:
[info] Starting Neo4j Desktop 1.3.11 @ Windows_NT 6.1.7601
[error] Protocol Manager type error: url must be string. url = undefined
[warn] C:\Users\Kai.Neo4jDesktop\neo4jDatabases not found
[warn] Failed to parse manifest file for Graph-App[neo4j-bloom]. {
constructor: 'Error',
stack: 'Error: Graph-App[neo4j-bloom] does not contain manifest.json\n' +
' at Object.t.getManifest (C:\Users\Kai\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\\n' +
' at N.resolveConfig (C:\Users\Kai\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\\n' +
' at v (C:\Users\Kai\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\\n' +
' at async Promise.all (index 1)\n' +
' at C.getGraphApps (C:\Users\Kai\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\'

Hey, I had this exact same problem just a few days back and could find no way to fix it.

The way I got around it was by going back a few versions. I now have desktop 1.2.8 and it works fine so far.

It might be that you can go a couple versions after that.

Hope that helps.

1 Like

Thank you for the reply!
I would like to try it, but I can not find an option to download or change my current version to e.g. 1.2.8.
Could you tell me how you were able to go back some versions, please?

Sure thing. Basically, after you click the download, you simply edit the address in the command bar and replace it with the version you want. As below:

I hope this helps

1 Like

Thank you so much!
It automatically started the preinstalled DB, therefore it seems to work now!

Happy to be of assistance :slightly_smiling_face:. Good luck!

1 Like

I was able to fix this exact problem on Windows Pro 7 SP 1.

  1. I uninstalled an old version of desktop
  2. I upgraded Windows Powershell to 5.1
  3. I installed dot net runtime 4.8

Item 2 (Powershell) is probably the essential change.