Trying install Neo4j Spatial, throws: Database failed to start error

I put the latest neo4j spatial jar file :neo4j-spatial-0.26.2-neo4j-3.5.2-server-plugin.jar into the plugins file, then restart the project, it threw:Database failed to restart: DB [database-1fa326de-ca26-4175-a47b-f35affee437c] 'v4.0.2' exited with status 'KILLED' errror

If I removed the spatial jar then it could work. However, I need the plugins extentions.

Thank you!

The spatial plug-in 3.* is not compatible with NEO4j 4.. I don't know if the plug-in will be updated to version 4.
You could use/install Neo4j version 3.
with the spatial plug-in 3.*.
There are also native spatial functions in Neo4j (no need for plug-in) Spatial functions - Cypher Manual

We do hope to port the plugin to 4.0 sometime soon, but it is not yet clear when this will happen. The plugin is currently a community-supported project, so if anyone is interested in getting involved, please do!

Yep, I tried 3.5.14 ( if I remember correctly the version), the spatial plugins works! Thank you!

Thank you for the reply!

Dear Craig, do you have any news about Spatial plugin for 4.x?

Hi @vit.mareev, no news yet. I tried to port it this spring, but was blocked on the removal of explicit indexes from Neo4j 4.0, and we use explicit indexes in a few places in the library. Some places I need to replace it with something else, and other places I think we just remove the feature that uses it. If anyone is interested in giving this a try, let me know and I can support it. Otherwise I can get to it when I get a chance.

Hi @vit.mareev, we also faced the same problem when upgraded to Neo4j 4.x. What are you trying to do with spatial function ? are you loading a shapefile or are you loading an openstreetmap OSM file ?

I have built a custom solution outside the box for both shapefile and OSM files.

Let me know if you need further assistance.

Hi @dominicvivek06
Now we are using GitHub - neo4j-contrib/spatial-algorithms: Spatial algorithms for both cartesian and geographic data recommended by Craig here: What is the difference between the 'Spatial' built into Neo4j and the community spatial plugin? - #11 by craig.taverner

Hi @vit.mareev , super. Our database couldn't even start because there were more dependency errors. Since we need to parse a osm file which is xml file, we basically built a quick loader.

glad, the github worked for you.