"The client is unauthorized due to authentication failure

Got the data all set up in 4 csv files. Got to the part of the instructions that say: bin/cypher-shell. Asked for username and password.
I've tried usernames neo4j, my email address, and a username I always use when trying stuff out. I've tried the one password that I know for sure I entered when creating a demo account for neo4j.
I removed data/dbms/auth and then tried bin/cypher-shell, asking for username and password (it never asked me to create a password, btw), tried username neo4j and password neo4j and also the password that I used when I did the download, still no luck.

Isn't there someone who can help?

Please give some more information on how you're running neo4j. The default is neo4j/neo4j which you've already tried, meaning that at some point the password may have been reset. If you don't have your password, you may be better off creating a new database as I'm not aware of a method of recovering the admin password if you lose it.