Store copy failed due to store ID mismatch

I'm trying to start a cluster with 2 servers on the same network both are running Neo4j enterprise 3.4.10 on Ubuntu Server 16.04 LTS.

I got a test cluster working between the two servers then did neo4j-admin unbind to try and seed the clusters and seeded them with the same files across both servers using the import tool but am running into this error

2018-11-16 22:09:46.309+0000 ERROR [o.n.c.c.s.s.CoreStateDownloader] Store copy failed due to store ID mismatch

this happens on whichever server is the follower

Any help would be appericated.

ERROR [o.n.c.c.s.s.CoreStateDownloader] Store copy failed due to store ID mismatch
having same issue! Didi you got any fix??

Has anyone found a fix for this yet?

I found some references on SO that point to an issue with importing data; however, I haven't imported anything. I simply installed 3 clean copies, modified the .conf files for the cluster and started it up.

TL;DR - don't try to setup cluster immediately after install without getting each server working as a standalone.

Wanted to give a follow-up in case others ha e this problem.

For me, I followed the instructions for creating a new cluster and tried starting it. I didn't change anything except the neo4j.conf file.

While testing, I reverted one of the cores back to standalone and the server would not start.

The "fix" for me was to uninstall everything and then before configuring the cluster, I made sure that each server worked in standalone mode. This seemed to be the trick for me. After I configured the servers for cluster, it started up and bootstrapped without any problems.

1 Like

Hi All,

Is this issue got resolved?
I have tried configuring cluster faced same issue..

ERROR [o.n.c.c.s.s.CoreStateDownloader] Store copy failed due to store ID mismatch

Please assist. Thank you!

Did you try testing each server outside of the cluster to see if they work? That's what worked for me.