Restore not working

Trying to load the database from a dump file. The database we plan to load it into is GDB. We can load Neo4j without any issues.

What are we missing here ?

C:\Users\User\Downloads>neo4j-admin load --from=Neo4jDB.dump --database=GDB --force
Invoke-Neo4jAdmin : C:\Users\User.Neo4jDesktop\neo4jDatabases\database-9afe2c2a-5c93-4580-a73b-c870244bf47c\installation-4.1.0 is not a valid Neo4j installation. Missing
At C:\Users\User.Neo4jDesktop\neo4jDatabases\database-9afe2c2a-5c93-4580-a73b-c870244bf47c\installation-4.1.0\bin\neo4j-admin.ps1:13 char:7

  • Exit (Invoke-Neo4jAdmin -Verbose:$Arguments.Verbose -CommandArgs $Arg ...
  •   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
    • FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Invoke-Neo4jAdmin
In MAC, this worked for me:
neo4j-admin load --database=abcd --from=/tmp/xyz.dump
After successful run, you have to run this in System database:

After this,  you will see the database in the list. You can check this by running SHOW DATABASES.

Thank you - Tried that with the same result. The failure is on the load side. so I never get to the next steps.

Here are the steps I followed:

  1. Copied the dump file from another server to data/dumps folder in the selected database in Neo4j Desktop.

  2. Opened the Terminal from the selected database (had this database stopped)

  3. Ran this:
    bin/neo4j-admin load --database=abcdb --force --from=data/dumps/abcdb.dump

  4. Started the server and opened the browser. The created database will not be seen in the drop down list.

5.Select System database and run this: CREATE DATABASE abcdb.

  1. Finally you will see this database in the drop down list.

Sorry yes, I am not having a procedural problem. It works on my AMAZON linux server. Its blowing up with the error message when I run the same process on my PC because it
Invoke-Neo4jAdmin : C:\Users\User.Neo4jDesktop\neo4jDatabases\database-9afe2c2a-5c93-4580-a73b-c870244bf47c\installation-4.1.0 is not a valid Neo4j installation. Missing

Nothing to do with the commands. I have the dump file so I already got the rest to work. But the load is not and its failng with the error messages.


The issue that I just noticed in Desktop 1.4.1 is that after the restore the new database may appear in the drop down list of the databases via the browser:

but it does not appear in the actual "homepage" of the Neo4j Desktop:

Any ideas on how to refresh the homepage of the Neo4j Desktop 1.4.1 will be greatly appreciated

Edit the neo4j.config file. Stop the database before you make any changes. 

On the Project, you will see three circles next to 'Open button'. Select Settings to see neo4j.config file. At the top you will see:
# dbms.default_database=neo4j 
This indicates that neo4j is the default database. 
Edit this line to:


Please make sure that this line is not grayed out. If it is, then remove  '#' 
 Finally, start the database and when you open the browser you should see 'kroll' and not neo4j.

Thank you for your reply. Possibly I misrepresented what I meant. My point is that although I take for granted than in the Desktop the user should be able to create its own projects and name them as they like, the Database name under the project is right now arbitrary. You can give it any name that you like. It creates the neo4j and the sys databases.
My point was that as long as you import a database (Kroll in my instance) and you "create it" so that it appears in the drop down, it should appear on the front page, under the project.
Again, right now, the name of the databases under the project "is completely irrelevant to the actual name of the databases even if these databases has been set as default".
Actually, my point is what is the significance of the naming of the databases in the homepage of the Desktop.

@exonianp The databases you see in Browser are not the same thing as the DBMSs you see in the Desktop project. In Desktop you see your Neo4j instances, while in Browser you see the different databases available in the instance you're connected to.

Thank for your response.
So I guess it is more likely a case of naming and meaning conveyed with the naming. Why don't you name the "Databases" in the desktop as "Server Instances" to avoid the confusion?
It also seems to me that one cannot run more than one instance running at the same time (from the desktop). Is this an issue of licensing - because even in enterprise versions of the Desktop you can only run one instance...?
Given the fact that a single query execution can only utilise four cores (see this post/question: Allocate more than 4 cores (Windows?) in Neo4j ) it appears that some of us with machines with many cores, cannot fully utilise our (compute) time via the desktop.
Am I getting something completely wrong with the desktop functionality? Shall I stick to just unzipping neo4j server instances in different directories and running them separately, connecting to them via their respective terminal commands and forget the Desktop?

Select System database and run this: CREATE DATABASE abdb.
Finally you will see this database in the drop down list.
neo4j-admin load --database=abdb --from=/tmp/xyz.dump

For the record and the reference of others just to state that in Ubuntu one has to ensure that proper permissions are given to the directories of the database that was created via the neo4j-admin load :
sudo chown -R neo4j:neo4j /var/lib/neo4j/data/databases/
sudo chown -R neo4j:neo4j /var/lib/neo4j/data/transactions/

It may also good to have the server stopped during the load. After the load, change the permissions as above and then start the server.
Running the CREATE DATABASE command in the SYSTEM database is critical. If you run it on your default database by accident, you will wont see the new database. So drop the one created in your default database and execute the command it in the SYSTEM database context.