Refresh Sandbox

I'm working on the Adding Role Node. I tried to run a query to create these nodes and relationships but made a minor error. However in that script I nulled out the role name in the ACTED_IN relationship already, so I can't try to rerun this again. Is there a way to refresh the sandbox to get it back to starting conditions? I already tried refreshing the page and that did not work.

I found the Cypher code to put the sandbox back in the correct state. I think this would be a helpful tool though for future classes. It would make it easier to make mistakes and get the database back into working conditions.

Hello @jdbruner.10 ,

I agree. We will look into making the reset of the sandbox easier for users.


Can you share this code? I've done the same thing.

Hello @tick143 and welcome to the Neo4j Community.

The code to refresh the sandbox at the beginning of a Challenge will depend upon which Challenge you are on. If your graph is not validating after a Challenge, the best thing to do is to:

  1. Go to the sandbox site and terminate the sandbox for the course. (right down arrow to see the sandbox actions)
  2. Refresh the Challenge page in the course. It will take a minute or so the the new sandbox to be created. (wait until you see $neo4j in the embedded sandbox pane.
  3. Always use the embedded sandbox for your work in the challenges as it has the code to reset the sandbox for the challenge and validate your work.