Problem with apoc procedures


I have the apoc jar in the plugins directory and file.cyp in the import directory.
I want to use call apoc.cypher.runFile("file.cyp"); to execute cypher from script file, and i have the configuration as below:


When i run the call apoc.cypher.runFile("file.cyp"); i have this error:

Failed to invoke procedure `apoc.cypher.runFile`: Caused by: java.lang.RuntimeException: Import from files not enabled, please set apoc.import.file.enabled=true in your neo4j.conf

any help ?


did you restart the graph after updating the conf ??

Yes but i have the same error

Check if this property is at multiple places. And if it is in cluster, Make sure this property is added in all the instances and restarted.
Working file for me on neo4j community 3.5.14.

it was not in the conf and i add this line so its not in multiple places.
I am with neo4j entreprise 4.0.0 not in cluuster mode

Fixed, the version of apoc was not compatible with neo4j version.
I installed the last version apoc- and it works.