Problem when running Neo4J Community 3.5.3 console on Mac OS High Sierra

Dear all,
I have downloaded the latest version of neo4j community (3.5.3) and everything seemed to be fine. However, when I try to run the neo4j console I get some problem I cannot really understand. For your convenience, I attach a screenshot of the terminal window with the error. It might be important noticing that if I run 'neo4j version' I get '3.2.0', which is the version I have currently installed (and working properly) on my laptop. Any help would be appreciated.

Thanks and regards,

As update, I upgraded my OS to Mojave and my java version to JDK 11. I retried with running neo4j console and failed again, exactly as described above.

Now I tried to download and install the latest Neo4J desktop app with the hope of creating a local graph and then try to import a dump of the database. Of course, when I try to create a new database the app fails with the known problem of "Failed to change password". The issue was supposed to be solved in 1.1.16, but apparently the problem is still there in 1.1.17. The older posts around the Desktop issue suggest to run the community server in background and the Desktop app on top, so I re-downloaded the neo4j server community version and, of course, I am back to the point where I cannot run the neo4j console, nor start the server from the terminal.

I cannot believe that I lost 3 weeks and still I am not able to run the neo4j server on my laptop. Any help would be greatly appreciated.

Now I can run some Neo4j server on my laptop, which however seems not to be the one I downloaded. When I run "./bin/neo4j console" I get Neo4j 3.2.0 running, even though I have removed everything about its installation. As a plus, I can now connect with Bolt and explore the data I had in the graph, however if I try to download APOC and other plugins for 3.5.3 of course I get errors and the server fails to execute. I have checked that the Desktop installation did not carry any old Neo4J driver and have deleted any existing folder related to the previous versions. The only "old" part is the database folder. Any ideas?

Thanks and regards,