Please help me install Neo4j Community, Java 11 Doesn't Seem to Be Properly Working . .

I have Windows 10.

  1. I followed the installation instructions given here: Thanks for Downloading Neo4j - Neo4j Graph Data Platform

  2. I extracted all the files.

  3. Then I opened the CMD prompt, changed directories to the top level of the downloaded files and ran "\bin neo4j console"
    A. in the CMD I see an error: "WARNING: ERROR! Neo4j cannot be started using java version 1.8.0_261
    WARNING: * Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j Server.

  1. So I went here to download Java 11: and I ran the installer

  2. I then repeated Step 3 above, running "bin\neo4j console", and I see the exact same error.

What am I doing wrong here?

1 Like

I'm having the exact same issue on 11/30/2020

I am getting the same message.
I also checked my java version using - java -version.
It is version 11 ....

But neo4j console still won't start.

Did anyone resolve this?


1 Like

Yes, I solved it on my Windows 10 computer, when I started the neo4j-admin the same issue appeared.
I checked my system variables and found JAVA_HOME pointed to Java 8 installation. Change it by Java 11 folder works perfectly.

Hope helping.

the the Java 8 install path still defined in the PATH environment variable?
or is environement variable JAVA_HOME referring to the Java 8 install path?

see Environment Variables for Java Applications - PATH, CLASSPATH, JAVA_HOME or similar

1 Like