Pentaho with neo4j

Continuing to make some progress with Neo4j and Pentaho (I think I see a how-to article forming...)

I've got several queries working, but I have trouble if I have (2) Neo4j Cypher steps within a transform.
It throws a strange error:

Could not gencsv Neo4j connection 'myneo4jserver.local' from the metastore
org.pentaho.metastore.api.exceptions.MetaStoreException: Unable to verify if namespace 'Neo4j' exists

Any pentaho experts out there? Thanks!

OK, I wanted to post an update:

I never really figured out how to solve the error, but I figured out that if I ran my transforms from a file repository (instead of a database repository) they worked as expected. Not sure why, but the database repository was not working reliable when connecting to my neo4j datasources. (seemed fine with my other JDBC queries oddly enough).

Since I'm brand new to Pentaho, I can't really draw many conclusions other than the database repository must have requirements/behaviors that are a bit different...

I'm making progress, and I'm drafting a future how-to for Pentaho and Neo4j ...

And using @matt.casters Neo4j Cypher kettle plugin really makes it easier.

With the option to supply parameters as a map list, you can then UNWIND $mapvariable
and use named parameters instead of the indexed ? variable in the "Execute SQL Script" task that makes complex queries difficult to keep track of parameter usage.

...more to come!