NotFound - gcloud compute instances create

Hi, I'm having trouble creating a neo4j instance on Google Cloud Platform, following the directions here: Neo4j standalone instance (VM-based) - Operations Manual.

I get e.g. The resource 'projects/launcher-public/global/images/neo4j-enterprise-1-3-4-9' was not found, for any version I try. I know this worked a few months ago – did something change?

Thanks for any thoughts.

1 Like


You did everything right -- the image name changed slightly . Please use neo4j-enterprise-1-3-4-9-apoc. The reason this name changed is that APOC and graph algos are now included with the image!

I'll try to make sure we update the documentation. I know exactly the page you were looking at that brought you to the wrong string, and we'll fix it.

Ah, great, thank you for that quick response! And yes, that seems to be working.

1 Like

I am having all kinds of issues getting either Enterprise or Community working properly, especially with plugins from e.g. Graphaware ( – ResourceConfig instance does not contain any root resource). How are people feeling about the Neo4j Enterprise CC VM available in the GCP marketplace? I certainly don't need that kind of power yet, but I do need to get this upgrade wrapped up asap! Thoughts welcome.

Maybe @Christophe_Willemsen can help here? The GraphAware plugins are great - but I too have had some version compatibility issues in the past. I know that it's important to install the right version of the overall framework plus whatever extension you're using, plus if you're mixing with APOC (which you are, because the Google VM images come with APOC) -- you need to check the version on that as well.

A useful thing would be for you to do ls -l on your plugins directory so we can see exactly what versions of what you have, and also include an exception from your neo4j.log if it's not working. Please consider opening a new thread about plugin compatibility there, so that others who know about plugin compatibility can find the post and maybe jump in.

As for the Neo4j Enterprise CC VMs available on Google Cloud - they are literally the same image you're already using, but with a different config. So if you're having plugin challenges that different config won't help or hurt, it'll just give you a much bigger database cluster.

Thanks David,

That's useful to note the CC VM won't help (plus didn't want to explain $ to boss!). Except for some surprising versions on the built-in plugins, I think this should match for my current attempt (Community 3.4.9):

-rw-rw-r-- 1 ubuntu   ubuntu   9.8M Oct 15 16:41 apoc-
-rw-rw-r-- 1 ubuntu   ubuntu   1.2M Oct 15 16:41 graph-algorithms-algo-
-rw-r--r-- 1 jiropole jiropole  14M Oct 31 14:14 graphaware-server-community-all-
-rw-r--r-- 1 jiropole jiropole  27K Oct 31 14:14 graphaware-uuid-

I'm going to go back and re-repeat the whole thing with enterprise, to see if I missed any steps the first time around.

Edit: oh, and I think this exercise answers my question: If I set those two new plugins executable, I no longer get the "root resource" error. Maybe my day is looking up!

Off of the top of my head what you have looks right. Remember to post the full content of a specific exception if you run into one.

Thanks for pinging me @david.allen, we've had some compatibility issues with apoc dependencies and ours in the past, that said they are solved as we have a step in our build that embed apoc for avoiding this completely.

The issue you are seeing is that the graphaware server plugin is or not present or not readable, I can see the ownership of that jar is different than for APOC.

Make sure to post your configuration as well.


1 Like

Thanks Cristophe,

Yeah, I've had occasional version issues, but usually it was my own error. In fact, it started working after changing the permissions to executable, however, I'm not sure that was the root issue. I was playing with VM level configs, and restarted a few times, and suddenly all was well – I hate when I miss the actual step that fixed it!

1 Like