NeoVIS Problems with Captions - only "_node" is shown


i just started using neovis. My example is simple and I get data - But with 2 labels I have "captions" problems . after draw the caption is "_node"

Her is my code - the rest is the simple example from the github repo ...

            var config = {
                container_id: "viz",
                server_url: "bolt://",
                server_user: "neo4j",
                server_password: "PASSWD",
                labels: {
					"topic": {
                        "caption": "name"
                    } ,
                    "course": {
                        "caption": "short_name"
                    } ,
                    "person": {
                        "caption": "name"
                relationships: {
                    "allowed_to_teach": {
                        "caption": false
                initial_cypher: "MATCH (per:person)-[r1:allowed_to_teach]->(cou:course)<-[r2:hasCourse]-(to:topic) RETURN * "

And here is a screenshot?

what do I do wrong? The Names of the nodes with label person are ok.
Thanks for help?

Not seen that before. Anything in your JS console?

In the past it always worked fine for me. Are you using the latest version?

Perhaps also raise a GH issue on the repository.

I use

... src=""> ....

also tried it with 1.5.0 and 1.4.0 .. same error

there was an encoding error when i copied the example form the github. but with <meta charset="utf-8"/> the error was solved ....

so I have no idea ...
thanks anyway ... i will open a GH in the repo ... rob

I opend this issue in github - looks like a bug (to me), because of 2 or more labels

Short version : multilabel is not supportet at the moment ... it must be the FIRST label! I have a workarround so it is fine for me ...

Hi there,
if you are still interested in neovis visualisation, have a look to my simplified neovis example
You can easily adapt the code to your problem or db. The idea is to use only the core of neovis, ako connector, and delegate the interface to visjs after the rendering. Please observe the circumvention of the neo4j-s vs. trust: standard neovis is not compatible with newer neo4-s schema and its 'use strict'