Neosemantics plugin not installing


I've been trying to install neosemantics plugin (both and with neo4j desktop (tried both 1.2.6 and 1.2.8) on Mac. I have placed the jar file in the plugins directory and also added
"dbms.unmanaged_extension_classes=n10s.endpoint=/rdf" in neo4j.conf. However, I keep getting the message from the neosemantics graph app "Plugin required", giving me the instructions I have already performed. Any clues please?

Hey @vdritsou, did you restart the database after installing the plugin? I had noticed a bug in the app that you sometimes need to click the button a few times before the screen clears but I thought I had fixed it.

You can verify if the plugin has been installed by running the following query in Neo4j Browser:

CALL dbms.procedures() YIELD name
RETURN count(*) > 0 AS installed

Hey @adam.cowley,

Thanks for your reply. I did restart it, multiple times. I guess the plugin is not installed at all, since there are no dbms procedures started by neosemantics. No such procedures are initiated, I've checked it with both versions of neosemantics ( and and for both versions of neo4j (1.2.6 and 1.2.8). However I cannot understand why it does not get installed.

The app runs a similar query to the one I posted above so it will only disappear when it finds procedures that start with n10s.

Are you sure that you have copied the jar file into the correct folder? What version is the neo4j database?

What operating system are you using? There may be security settings that are blocking the jar file for some reason.

The path where I have copied the jar is:
/Users/vicky/Library/Application Support/Neo4j Desktop/Application/neo4jDatabases/database-82659120-3218-4de9-b855-2e68fce25fb4/installation-4.0.4/plugins/
It's a 4.0.4 db running on MacOS Catalina 10.15.3.
I have also tried with a 3.5.14 db, but without success, same behavior with this version as well.

Is that the same path as the database that is currently active in Neo4j Desktop? You can check by clicking the three dots in the top right hand corner of the card and click Manage, then click 'Open Folder' on the Manage screen.

The plugins folder should have the jar file in there, if not paste it into there and restart the database. If that doesn't work, try downloading the jar file again from github.

No, it wasn't, you are absolutely right. It's working, I can see the dbms procedures with the prefix n10s running now. Thanks for the help @adam.cowley!