Neo4j wont start

So fresh copy of parrot os installed.
fully updated and upgraded. Neo4j version 3.5.3 installed.
when I Sudo neo4j start console i get
Active database: graph.db
Directories in use:
home: /usr/share/neo4j
config: /usr/share/neo4j/conf
logs: /usr/share/neo4j/logs
plugins: /usr/share/neo4j/plugins
import: /usr/share/neo4j/import
data: /usr/share/neo4j/data
certificates: /usr/share/neo4j/certificates
run: /usr/share/neo4j/run
Starting Neo4j.
WARNING: Max 1024 open files allowed, minimum of 40000 recommended. See the Neo4j manual.
./bin/neo4j: line 451: /usr/share/neo4j/run/ No such file or directory
./bin/neo4j: line 450: /usr/share/neo4j/logs/neo4j.log: No such file or directory

I read a similar thread on this forum but that fix did not work.
Can any one give me some tips as to what im missing please.

Hi Benjamin,

3.5.3 is not the latest in the 3.5 branch and I remember similar issues in the past.

You might want to check if the /usr/share/neo4j/run directory exists, if not you might need to create it.

If this is a new install I would recommend using the latest release in 3.5 which is 3.5.17 or the new 4.0.3 release.

See for more details on getting specific versions.

As a side note: it might very well be that starting it via the console gives issues while starting it as a service works ok. Make sure that the installer did not start the service for you already, that might cause issues too.

also, although i cant say this is directly related but

So fresh copy of parrot os installed.

but per there is no reference to support for 'parrot os'. It may work? but suspect its not something we have fully tested

Thanks for you reply.
It seems that installing neo4j is a serious undetaking.
if i sudo apt-get install neo4j=4.0.3 it returns
version 4.0.3 for neo4j was not found.
Following the link you sent send me to another link

I can follow the instructions to here

sudo add-apt-repository -y ppa:openjdk-r/ppa

then i get another error
"Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 95, in
sp = SoftwareProperties(options=options)
File "/usr/lib/python3/dist-packages/softwareproperties/", line 109, in init
File "/usr/lib/python3/dist-packages/softwareproperties/", line 599, in reload_sourceslist
File "/usr/lib/python3/dist-packages/aptsources/", line 91, in get_sources
raise NoDistroTemplateException(
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Parrot/n/a"

There where plenty of errors on the way that i had to fix but this one I simple did not know what to do with. Any ideas.

And thank you for prevois comment and help.

the documentation at describes the install. I just tried and was sucessful, though I'm not using parrot os bur rather Ubuntu
Have you properly set up the repository?
Also the sudo apt-get install neo4j=4.0.3 is incorrect. The doc states

Install Neo4j
To install Neo4j Community Edition:

sudo apt-get install neo4j=1:4.0.3
To install Neo4j Enterprise Edition:

sudo apt-get install neo4j-enterprise=1:4.0.3

In short, my experience was

wget -O - | sudo apt-key add -
--2020-04-21 20:50:52--
Resolving (,,, ...
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6342 (6.2K) [application/pgp-keys]
Saving to: ‘STDOUT’

-                                        100%[================================================================================>]   6.19K  --.-KB/s    in 0.004s

2020-04-21 20:50:53 (1.65 MB/s) - written to stdout [6342/6342]


echo 'deb stable 4.0' | sudo tee /etc/apt/sources.list.d/neo4j.list
deb stable 4.0
$ sudo apt-get update

 sudo apt-get install neo4j=1:4.0.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libpython-all-dev libpython-dev libpython-stdlib libpython2.7 libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libsqlite0
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  cypher-shell neo4j-enterprise
The following packages will be upgraded:
  cypher-shell neo4j neo4j-enterprise
3 upgraded, 0 newly installed, 0 to remove and 290 not upgraded.
Need to get 206 MB of archives.
After this operation, 98.0 MB disk space will be freed.
Do you want to continue? [

Holy Moses, You did it. Thank you.
I made an assumption that the 1 in sudo apt-get install neo4j=1:4.0.3 was version one, and i did not want that. so omitted it.

I do not know if the repository is set up correctly but i followed the guide as closely as i could substituting my information where relevant.

Thank you,

happy to see you have found some success.
Regarding the version and the leading 1 the documentation Debian - Operations Manual states

Note that the version includes an epoch version component (1:), in accordance with the Debian policy on versioning.

so yeah the leading 1: is important

this software is a nightmare. I have installed an upgrade and it will not show now. This is bullshit.

Agreed! I've tried fresh installs on two different Windows 10 machines and it crashed on startup both times. Not ready for prime time. Also, why make users download the 'latest' release and then require an update to run the first time?

Can anyone recommend a different software package for working with Cypher?