Neo4j performance good on one server, bad on another

I am having trouble with the Neo4j browser.

I have 2 servers at AWS that have the same resources, but when I connect to one of them, the browser works great. On the other, the browser is terrible.

Other people on my team do not have this problem

I've cleared the cache in chrome and do not know what else to try

Just swapped this to Browser category to get someone to help out!

Can you provide a little more insight of where the problem occurs?

Sorry that I was vague.
In the Graph tab where it draws the circles, it takes a long time to render.
When I switch to any of the other text tabs (Table, Text, Code) it work fine.
If I run the exact same query on another chrome tab pointing at the production database, it renders very quickly

If I try to click on a circle, it takes several seconds to select it and put the information in the status bar at the bottom or the pane

If I try to expand child relationships, sometimes it takes so long (with fewer than 10 children) that chrome asks me to close the page.

I'm hoping there is just another place in chrome where I need to clear something

Thank you

Corey Lapka

1 Like

What happens if you use incognito mode?
Do you have a proxy setup? Different VPC for the servers?

1 Like

It renders very quickly using Incognito mode.
I'm not sure about the VPC

You can try clearing your local storage.
Use regular mode (not incognito)
Open Developer Tools (three dots , More tools, Developer Tools)

To see what part is slow Click Network - refresh the page or do the slow query. This obviously won't fix anything
To clear the local cache, Click Application then Clear Storage then click Clear site data.

What happens after you clear that?

Still the same slow rendering.

Sorry to take so long to get back to you, Friday was busy.

When I click to expand the child relationships, it pauses for quite a while before it calls the network

That looks like a timeout situation.
Did you clear the cache?

yes, I had done that just before taking the screenshot

I'm out of ideas. Incognito works fine, clearing the cache didn't help. Proxy settings different?

Ok, thanks for trying. I'll jus keep using incognito mode. I'm glad you had that idea.

Try Neo4j Desktop, I found the Neo4j Browser to have way better response with Neo4j Desktop application. You can connect remote servers to it from AWS pretty easily.

Hi Corey,

What version of Neo4j and Browser (click on the Neo4j icon bottom left) were you using.
I think I saw you were using Docker.
Can you give me the output from :config, my output

Yes we are using a docker container with the same startup parameters

These settings are the same

Good server
Neo4j Browser version: 3.2.10

Neo4j Server version: 3.4.9 (community)

"cmdchar": ":",
"maxHistory": 30,
"theme": "normal",
"initCmd": ":play start",
"initialNodeDisplay": 300,
"maxNeighbours": 100,
"showSampleScripts": true,
"browserSyncDebugServer": null,
"maxRows": 1000,
"shouldReportUdc": true,
"autoComplete": true,
"scrollToTop": true,
"maxFrames": 30,
"editorAutocomplete": true,
"editorLint": false,
"useCypherThread": true,
"enableMultiStatementMode": true

The settings are the same for the bad server?

I included both, they look the same to me, but I may have missed something