Neo4j local cluster start failed

I am trying to set up a local cluster in neo4j and following this tutorial ( I have downloaded the latest enterprise version 4.1.1 and have followed all the steps mentioned in the tutorial. However I am confused at one step where it is mentioned that we should move to bin directory and run command " neo4j start " . When I run this command it says neo4j service not found so I searched about it and found that I should install neo4j as a service first then the start command will start the service. When I install it the service will run for the core-01 instance, following the tutorial for core-02 and core-03 I am supposed to start neo4j also but again the start command will not work unless I install it.

Following this am I supposed to install 3 different services or it is supposed to be a single service for the whole cluster of 3 instances? If single then the neo4j service will always points to the core-01 instance.

Skipping start command If I run the command neo4j console in the bin directory of 3 instances then I get this error in all three consoles

Database 'system' is waiting for a total of 3 core members.
Failed to start Neo4j on dbms.connector.http.listen_address, a socket address. If missing port or hostname it is acquired from dbms.default_listen_address

How I am supposed to handle this?? Am I not setting neo4j service properly or there is some issue in configuration ?