Neo4j export whole database to ARRAY_JSON

I tried to use an APOC procedure from here to export the DB using the following:

CALL apoc.export.json.all("all.json",{useTypes:true})

I can successfuly export to JSONL. However, I am not able to change the JSON format to other available formats such as JSON_LINES, ARRAY_JSON, JSON or JSON_ID_AS_KEYS. According to the documentation the following should work but it does not:

CALL apoc.export.json.all("all.json",{config:{jsonFormat:'ARRAY_JSON'}})

The result of above procedure is in JSONL but not ARRAY_JSON.
Cheers, A

They fixed it in the new apoc release but for now directly enter the jsonFormat parameter in the bracelet without the config:{}

I have tried that (simillar to yours) but did not work.

Many thanks

Weird it worked for me, might the way you return your result too.
For me, even with the JSON_ARRAY format it wasn't what i needed for keylines so I just did it manually with a bunch of map and collect.

What's your version of APOC? You can open the plugin folder using the tree dots by the blue open button and chose Open Folder -> Plugins. Copy and paste the path showed into your file manager if it doesn't open.

In the plugin folder, you can see your APOC version on the apoc file name.

Thanks Gabriel. The problem was the version and it is working now with the latest APOC release from here