Neo4j embedded - data corruption


We have neo4j 2.2.5 embedded into java service.
Some how properties data was corrupted.
These error appears threw cypher execution.

NodeImpl#123129585 not found. This can be because someone else deleted this entity while we were trying to read properties from it, or because of concurrent modification of other properties on this entity. The problem should be temporary.

We tried to use store-utils-21 without no luck , every execution fails because of compilation error.
What version of neo4j we should provide to store-utils ?
We tried 2.2.1 - 2.2.10.

Any help appreciated.

Can you say which compilation error do you have ?

[INFO] -------------------------------------------------------------
[ERROR] /..../store-utils-21/src/main/java/org/neo4j/tool/[11,41] error: package does not exist
[ERROR] /..../store-utils-21/src/main/java/org/neo4j/tool/[12,33] error: cannot find symbol

I assume this error is from the branch 21 of the project, but your Neo4j version is 2.2.5, so you should use the branch 22 instead.

I have tried to compile both branches on my laptop, and it works (excuse number 1 of a dev ^^).

Can you try to call maven like that : mvn clean compile -U ?