Neo4J Desktop load local CSV file issue

Hello! Could someone help preserve my sanity and help me with this issue please? Have wasted a couple of days on it so far.
I do not seem capable of uploading simple CSV files from the local import directory within Neo4J. I have tried multiple times referencing the many examples on the Neo4J site and elsewhere but always get a response similar to the screen grab or Neo.ClientError.Statement.SyntaxError - none of which are helpful. I have checked neo4j.config etc but to no avail. I know this is a stupid trivial error but I just dont know what it is :slight_smile:
The only success I have had is loading http files from the no4j site.
cheers, Mark

OS X 10.13.6
Chrome 79.0
Neo4J Desktop 1.1.22
MacPro 32Gb

Well there is this strange single quote in front of the file name ('entities.csv). Is th ename really containing that single quote??

I guess your Load command should be


Hello Kris!
Thanks for your comment. I have tried single quotes, double quotes and even 'tick marks' and it seems to make no difference. What is interesting is that your example does not include the file:/// prefix.

Well that might be my laziness ;-).
But none the less you are usng both doublequotes and a single quote in your screenshot.
So remove the single quote and you are ok I think

Fixed! You are a star Kris! Very sloppy on my part, this works fine.
LOAD CSV WITH HEADERS FROM "file:///entities.csv" AS line

Sanity restored!
Many thanks from a wet and chilly London,