Neo4j Desktop Issue

I recently used Neo4j Desktop version 1.2.5 with Window 10. It worked well with some data analytics. But, now, the Neo4j desktop application can't open so that I can't do anything. I see the Neo4j desktop.exe (Admin) is running in the background process in my task manager. However, I can't see the Neo4j desktop screen. Any help would be appreciated. Thanks in advance! I need it seriously for work.

Hey, can you confirm for me the version of Neo4j Desktop you are using, it will be a version 1.x.x number. 1.4.7 is the most recent version. Thanks!

1 Like

Yes. Mine is Neo4j Desktop 1.2.5.

I'd definitely recommend backing up important Databases and then installing / upgrading to the most recent version of Desktop as that version is now quite old. Let me know how you get on.

1 Like

I just download and installed the new one version 1.4.7. But, I can't open the screen yet. How can I open it,? Thanks! The installed location is E:\GraphDatabase\Neo4j Desktop.

I found the same issue with new version. It can't open yet. Any solution? Thanks! I need it for my school assignments. Please help me...My old databases are located in " E:// Neo4jdatabases". They are not the same location now. How can I resolve them to use those existing databases with new one?

Hi there. Have you tried restarting your computer & trying again to open the desktop application? If there are any lingering processes running that will clear them out.

1 Like

Sure! Already restart my computer. But, it still can't launch the neo4j desktop screen like before.

Hi @laelaeshwe89 ,

a long time ago i had a similar trouble , could you try to see on error log ? in my case the start up process was looking for a .json file , ive been resolved looking the file in the backup folder and "copy & paste" at the new path and ready !!


1 Like

Yeah, I agree, I think it'd be useful to look at your log file

1 Like

@laelaeshwe89 we're looking into the issue and think it could be to do with an issue with a cache relating to plugins becoming corrupted (might be similar to experience @ponceortiz is referring to).

Can you try deleting the file at:


and report back.

1 Like

Do I need to find this error log file, default-source.json file in my databases that I populated with Neo4j before? I'm looking up this json file . @ponceortiz @gregory.king @emma.nash. I will report it back here. Thanks for your kindly suggestions and possible solutions as I need it urgent.

You should be able to find it at C:\Users\[USERNAME]\.Neo4jDesktop\log.log (or E drive if that's what you're using)

1 Like

When I find it that error file in my drive where my databases are located, I see those log files....


It's the desktop-app log file we're looking for, not the database log files.

1 Like

if you run into issues with Desktop 1.4.7 on Windows could you try this and report back?

try asking them to delete the C:\Users[USERNAME]\AppData\Local\Neo4j\Relate\Cache\plugin-sources\default-sources.json file and see if that helps? We think that the reason for desktop not starting for some users might be that the cached plugin sources has become corrupt

1 Like

I unfortunately don't think the plugin sources file is the issue here anymore. But it would be really helpful to get the log file from either your new or old installation. It should be located in the root of the folder you chose as the storage location when you first started the app and it should be named log.log.

1 Like

When I look for the desktop-app log file, I see those files
Neo desktop logs