Neo4j desktop - Initialization error: TypeError: Cannot read property 'name' of undefined

Two days back, I deleted some unused projects from Neo4j Desktop (to create more space to load my next dataset). Today, when I tried to start up Neo4j Desktop again, I get this error -

I tried restarting Neo4j Desktop several times, and each time, it's the same thing.

I checked the "developer tools" tab, and there is a whole bunch of stuff in the console. I put all of it in this gist, if it helps.

Here's the relevant portion of the console which has this error message -

There are several questions on stack overflow where people report the exact same issue. Here's one from SO where Michael Hunger said on March 1, 2018 that it was a known bug and it would be resolved in the next release.

Other reported issues - 1, 2, 3

The problem is that the suggested solution involves deleting this path - ~/Library/Application Support/Neo4j Desktop and reinstalling Neo4j Desktop. I cannot do a reinstall since my thesis is on Neo4j, and all of my data (~around 400GB) is already on neo4j desktop. It also took me months to load all the datasets.

I'm hesitant to delete that folder even, in case it causes loss of data. I cannot delete the ~/Library/Application Support/Neo4j Desktop folder, because the folder size is ~400GB, approximately the same size as my datasets, so obviously my data is all in that folder.

I would appreciate any help, since I really need to finish loading my next dataset, where each relationship takes several hours to load, as it is.

  • Neo4j version: 3.5.14
  • Operating system: macOS Catalina
  • Neo4j Desktop version: 1.2.3

Hello Manish,

My recommendation would be to:

  1. Stop the database.
  2. Copy the contents of the database folder somewhere for safe-keeping. (In Neo4j Desktop, you can go to Manage -> Open Folder (for the database you are working on)
  3. In the Finder window, navigate to the data/databases folder and copy the entire database folder.
  4. Copy the contents of the graph.db folder somewhere for safe-keeping. (Important! This your backup!)
  5. Uninstall Neo4j Desktop.
  6. Reinstall Neo4j Desktop
  7. Create a new local graph in a project.
  8. Start the graph (this will create a new graph.db folder)
  9. Stop the graph.
  10. Copy the backup graph.db over the graph.db folder you just created.
  11. Start the graph.

Hopefully, this will enable you to start fresh with your saved database.


Hello Elaine,

Thank You for responding to my post. The problem is regarding this step -

I can't even get to this point in Neo4j Desktop, because as soon as it starts up, I get the error screen. Here, I made a video to show you the problem more specifically.

I can manually naviagate to Library/Application Suport/Neo4j Desktop/Application/neo4jDatabases in Finder, and all my databases are in there, but each database is named with a code, such as database-xxxxx-xxxx-xxxx-xxxx, and without neo4j desktop, there is no way of knowing which of my database created through neo4j desktop corresponds to which database-xxxxx folder in neo4jDatabases (unless there is a trick to this I'm not aware of).

Since you cannot start Neo4j Desktop, I recommend that you copy ALL of the database folders somewhere for starters.

Is it possible for you to determine which folders to ignore because they have not been used in a while?

To figure out which database you want to save is to open a terminal window and navigate to the bin folder of a database, then type ./neo4j start

This will start the database and then you can access it in a Web browsers via localhost:7474 where you can see if it is the database you are interested in.

Then stop the database: ./neo4j stop

Then I would uninstall Neo4j Desktop, delete all files, and re-install and place the database of interest in the databases folder as graph.db.


1 Like