Neo4j Desktop doesn't start up

Neo4j stopped starting up for some reason. Previously, it worked normally. I had restarted the computer after long time without restarting, and here's what happened.

It's stuck with this stage!
I tried to restart the computer again, uninstall and install neo4j, but nothing worked

  • neo4j desktop version 1.4.12
    I'm not sure if this is relevant, but here's the log:

[2022-04-01 21:51:34.714] [error] Online check error: {
name: 'TimeoutError',
message: 'Promise timed out after 5000 milliseconds',
stack: 'TimeoutError: Promise timed out after 5000 milliseconds\n' +
' at Timeout._onTimeout (C:\Program Files\Neo4j Desktop\resources\app.asar\node_modules\p-timeout\index.js:27:54)\n' +
' at listOnTimeout (internal/timers.js:554:17)\n' +
' at processTimers (internal/timers.js:497:7)'

Would someone tell me what to do, please?
I also tried to uninstall-clear cache and all related files-install, but that doesn't work as well

1 Like

Hi, the first thing to try is to update to version 1.4.15. We have done some fixes that could address this issue.

If that doesn't fix it, could you provide the Desktop logs? Log files - Neo4j Desktop