Neo4j Desktop does not restart after update

Hi community
I pushed the update button today in my Neo4j desktop on my local windows laptop to transition to the latest version of the desktop. Not 100% sure what happened after I pushed the button, but the desktop closed and nothing happened.

I tried to restart the desktop with no success.
I restarted my windows machine and tried to launch desktop, but no success.
I can see 2 entries for Neo4jDesktop.exe in the windows process manager, but the front end does not show up.

Any ideas on how to fix this?
Can I reinstall without losing my existing local Neo4j databases and configurations?


Hello Markus,

Here is what I would try:

  1. Kill both of the Neo4jDesktop.exe processes.
  2. Restart your system.
  3. Download the latest windows Neo4j Desktop.
  4. Make sure you have the latest PowerShell installed.
  5. Install Neo4j Desktop - it should use your existing application data area (database(s)

Hopefully, that will work for you.


Hi Elaine

This is the powershell version on my laptop. Do I need to upgrade?
C:\Users\mwissing>powershell -Command "$PSVersionTable.PSVersion"

Major 2
Minor 0
Build -1
Revision -1

Hello Markus,

You should upgrade to at least Major: 5 for the latest release of Neo4j Desktop 1.1.18

Best regards,
Elaine Rosenberg

Hi Elaine
I've got the same issue after reinstalling Neo4j Desktop On windows 7
I did all the steps :

  1. Killed all of the Neo4jDesktop.exe processes.
  2. Restarted my system.
  3. Downloaded the latest windows Neo4j Desktop.
  4. Updated PowerShell

After the reinstalling the UI doesn't starts. But I found 3 process running in task manager.
Before the previous update everysing was working great. So i tried to reinstall once again with previous version - but result is the same.
What shoud i do ? Can you help me please ?