Neo4j Desktop could not open the import folder

I used the Desktop on Windows 10 Pro. I am the local admin on Windows.

I got an error when checking the file import path.

I think this error is the cause that I could not import an graphml file stored in that "import" folder.

Any suggestion? Thanks.

I got a response from Neo4j support. I added the following line to the setting and it worked.


does it matter where in the settings u add the code?

I added it at the bottom of setting in 3.5.8 but I'm still getting the same error, any ideas?

Hello and welcome to the community!

Adding to the end of the settings file is fine. It will basically override anything that was set previously in the file.

You are trying to import using APOC and you have placed the file for import in the import folder for the database?

What is the Cypher statement you are attempting to execute?

A screenshot of the error would also be helpful.


Tried using the 'open folder' import function
and with LOAD CSV WITH HEADERS FROM "file:///Fcecsv.csv"

Thanks for the help


What happens when you select OpenFolder in Neo4j Desktop? That should open the folder containing the import folder, but it should not be opening the import folder itself.

At a minimum, your LOAD CSV statement should do something like:

LOAD CSV WITH HEADERS FROM "file:///Fcecsv.csv" AS row RETURN row LIMIT 10

When I select OpenFolder it does open the folder containing the import folder.

I checked the folder path in the error I was getting in the Neo4j browser and it was referencing a folder called 'import' but in the file directory the folder had been created as 'import directory' so i changed the folder in the file directory to match the error, i.e. changed 'import directory' to 'import'

Thanks for your help

Continuing the discussion from Neo4j Desktop could not open the import folder:

I have the same problem, actually it is not clear to me that the blue Trying to open banner is showing that this is an error. Is it?

i.e. What is supposed to happen when one clicks Open Folder on Neo4J Desktop?
When I click it it opens the Windows folder Import but then nothing happens after that. I am assuming this means there is an error, but I do not know why.

I have a graphml file in the Import folder, so it would be great to know what the expected result should be.

Anyone can help please?

Hello and welcome to the Community!

When you click the Open Folder button, it should open a finder/file explorer window for that project. You should see the data, import, plugin, lib, etc. folders. If you do not, I would want to know if you ever created a graph for that project. Can I assume that this is Windows? What version of Neo4j Desktop?

It it is windows, did install as Admin and grant anybody who uses the system access? Did you specify a non-default location for your installation files?


I'm having the same issue on Mac OSX Catalina. Neo4j Desktop 1.3.3. Attempting an eval.

I'll keep looking, perhaps someone here has the answer!

Open Manage and click on setting tab and chack to see if this is enabled:

LOAD CSV` section of the manual for details.

This works for me:

LOAD CSV WITH HEADERS FROM "file:///rc.csv" AS row
return row

Fetches the records in .csv file
I am on MacOs Catalina version 10.15.5 and Neo4j 4.1.0 and Desktop 1.3.3

Still I tried all the solutions in here but didnt work. Please help.

@itoriahimanshu Welcome to the community!

What platform and version of Neo4j are you using?

Where did you place the CSV file? It must be in the import folder for the database.


I found the easiest way to deal this is:

  1. In the Desktop, click on the three dots popup menu
  2. Choose "Manage" menu item
  3. Click on "Settings"
  4. Find the line: dbms.directories.import=import
  5. Change it to dbms.directories.import=ABSOLUTE_DIRECTORY_PATH
  6. Click on Apply button (in the lower right corner)

As I recall, you have to restart the DB.

For unix users, I'm not clear if the system recognizes ~ so I just used the absolute path just to be safe.