Neo4j desktop 1.3.5 can not start database on windows 10

I'm using Neo4j Desktop on a Windows 10 machine. I upgraded Neo4j Desktop to 1.3.5 as suggested. After that, I can not start my neo4j database instance which uses 3.5.19 of neo4j.

It says

Database failed to start: Database process terminated, see logs.. Check the logs

but the logs folder is empty. Please help

Hi @canbax thank you for reporting this issue.

  • Is this happening with all Neo4j instances you have installed or just one of them?
  • Do you have any other instances running?
  • Could you attach Neo4j Desktop's log? You can find it in this location: %USERPROFILE%\.Neo4jDesktop\log.log

Thank you,

I checked the logs there %USERPROFILE%.Neo4jDesktop\log.log They say they can not read somewhere in AppData folder.

After I uninstalled and deleted some folder inside somewhere AppData\Local manually and then reinstalling Neo4j Desktop, it worked fine.

I deleted some folders inside somewhere AppData manually. I think, when I uninstall Neo4j Desktop and check to delete all the folders, it should have deleted them but it didn't.

It is very strange that when I check the newest version on the website I see 1.3.4. But somehow my neo4j desktop suggested 1.3.5 and installed it.

Thank you

We have a phased release schedule, first we only show updates, then if everything is ok we update the download page. There was an issue with 1.3.5 where in some cases Desktop was looking for a non existing path and that was causing people to get stuck on the loading screen, so we reverted that release.

Just to clarify, after reinstalling Desktop you're now using 1.3.4, right?

Could you try the latest pre-release (1.3.5-dev.12) and let me know if that one works fine for you?

Yes I'm using 1.3.4
I will write here when I tried pre-release