Neo4j Browser Sync got very slow

I'm using Chrome as the Browser. But my browser got very slow after I signed in for Neo4j Browser Sync.

This is what I did: 1) I checked the box for Sign in/Register for Neo4j Browser Sync since I wanted to stored my favorite Cypher scripts. 2) Running pretty well for a hour or so, the Chrome began to become slower and slower. 3) I have to signed out and even clicked "clear local data" button. No help.

Can you please help me to resolve the issue?

I can access the Neo4j from a Firefox browser (without Neo4j Browser Sync) runs fine and fast.


I also tried the Neo4j Browser Sync in Firefox, now the Firefox browser became slower as well. So this issue is not Browser specific.

1 Like

In Firefox,
Privacy & Security
Cookies and Site Data
Manage Data…,
Deleting the URL line associated the Neo4j server will get back to the speed. This can keep my favorite scripts sometimes, but not very repeatable.

Don't know how to do it with Chrome. Appreciate if Neo4j folk can give the help or hint on this issue with Browser Sync.


1 Like

Hi Tao,
I have to say that I have exactly the same problem, and it is even not computer dependent (with different OS : archlinux, windows 10). I suspect that it is related to the configuration file of the database. However, I am not that familliar with this file, so if anybody has ideas, they would be really welcome.

Thakns a lot,


1 Like

try this

I am having this same issue. As soon as I log into the cloud, all of my queries and my interface become very slow. I have to log out and clear all cache for the interface to work well again. This is not great, because I would really love the cloud sync of my queries.

Has anyone found a way to solve this?


I had the same issue and ended up switching over to Neo4j Desktop to use Neo4j Browser to fix the issue.

How are you cloud sync'ing your scripts over Neo4j desktop? I don't see Browser Sync with Neo4j desktop, or how to save/transfer my scripts easily to another computer of mine

1 Like

I am having the problem on both Chrome and Firefox

1 Like

I have this problem on Ubuntu, using Chrome. Eventually I have to kill all neo4j connections, kill chrome, wipe the chrome cache and go back in again. Its a pain. This only started happening for me on Neo4j Enterprise V4.2, Before that it worked very well.

1 Like