Neo4j browser Issue


I upgrade Neo4j community edition from 3.5 to 4.2. After upgrade I see the service is running but i am not able to access "http://localhost:7474/browser/". I am seeing message "Firefox can’t establish a connection to the server at localhost:7474.".

Before upgrade it was working fine. I followed the upgrade instructions and still not able to understand where the issue might be?

I took the backup of 3.5 config file and replicate to new config file of 4.2.

Also if I get step by step uninstalling Neo4j instruction, I would like to try that?

Any help is greatly appreciated.

Hi @myrights99 ,

Check these settings in particular:

For 4.2.3, the default out-of-the-box looks like this...

# Bolt connector

# HTTP Connector. There can be zero or one HTTP connectors.

# HTTPS Connector. There can be zero or one HTTPS connectors.


Thank you Andreas for your reply. I checked that & they are correct. settings are same as on 3.5 before upgrade.

Ah, ok. Is there anything troubling in the logs? Take a look through logs/neo4j.log to see if anything look wrong.

  • ABK

Thanks for your reply. I end-up uninstalling and then reinstall. it worked fine after that.

1 Like