Neo4j-admin import successful but no data shown in database

I am using Neo4j Desktop with windows 10. I created a new database, imported a small csv file using the sample movies.csv. It says successful with 3 nodes added. The database shows zero nodes. Some post says that the neo4j service needs to be restarted. Not successful with the command (service not found). So I shutdown neo4j, still the same. I restarted the computer, still the same. I understand this can be down via load from csv but if there are big volume data, import should be a lot (10 times) faster according to what I read than load from csv. Import and export are basic functions, couldn't them be made easier? particularly for windows users. I guess it works better with linux.

Just as a comments on the load csv from file, here is the what exampled on the website, and here is what got from the system:

I think there is a confusion about how the data loads work.

  1. You can use neo4j-admin import command to use large CSV files to create a new database. The neo4j server cannot be up as this is an offline operation. This does not use Cypher.
  2. Using LOADCSV. For this the server should be up and running and uses Cypher to create the data.

It works same both in Windows or Linux. There is no difference.

In the case where you are getting error after loadcsv line you need to have some cypher to process the data. That line by itself will give error.

For example

LOAD CSV WITH HEADERS FROM 'file:///movie.csv' as line
return line limit 1

This will load the file if it exists and returns the first record in the file.

Make sure the file is in "import/" directory for Neo4J install.

I am having a similar issue where I run the admin tool import and see a new database in my /databases directory. I even get the following output after running the import command:

IMPORT DONE in 2s 363ms.
  6 nodes
  9 relationships
  24 properties
Peak memory usage: 440.2MiB

When I open the console or desktop I cannot see the database as an option in :sysinfo

I resolved the issue. The steps I found to successfully import a set of CSV using the admin -import tool is to:

  1. Stop the server
  2. Run the admin -import tool and use --database=aDatabaseName
  3. Start the server
  4. In the console switch to the System database using the pulldown control
  5. Run the following command at the system prompt: create database aDatabaseName
    (should be the same name set in #2 above)
  6. Switch to the database just created using the console pulldown control

I was able to see the database nodes and relationships I created following the above steps