I've been running neo4j 3.5 from a docker container on a ubuntu 18.04 server. I do my development and browsing from a windows box on the same LAN, using the Chrome browser. This is my startup script:

docker run \
--publish=7474:7474 --publish=7687:7687 \
--volume=$HOME/neo4j/data:/data \
--volume=$HOME/neo4j/logs:/logs \
--env NEO4JLABS_PLUGINS='["apoc"]' \
--env NEO4J_AUTH=neo4j/test \
--name=neo4j \
--restart=always \
--detach \

This has worked nice as pie.

I killed and removed that container then changed the last line of the script to neo4j:latest and ran the script again. I browse to same as before and I get the following:

It took me a day to figure out that the issue is related to the browser. I spent another day trying everything I could find to fix the browser issue. I've given up for now and gone back to version 3.5.

If anyone can shed some light on this it would be most appreciated.

Hi, I think that this is a browser error. Please you can review your firewall, cache, proxy settings or extensions...


I had another go at this today. Here is what I did:

  1. Reset all Chrome settings to default.
  2. docker system prune
  3. docker run
    --publish=7474:7474 --publish=7687:7687
    --env NEO4JLABS_PLUGINS='["apoc"]'
    --env NEO4J_AUTH=neo4j/test

Now it is working!

Thank you Jaun for your suggestion, it worked like a charm.