Neo4j 3.4 Set up issue without error message


This is a question regarding setting up Neo4j 3.4.

I just upgraded neo4j 3.4 from Neo4j 3.3. I configured the neo4j.conf so that I can access my previous data. However, when I started neo4j on the browser, I got the browser and there is no error message. But I cannot run a cypher query or anything. Can anyone shed some light by guiding me what to look?


Are there any error messages in the log file?

No there is no error message in the log file... which is odd. I guess everything seems to work, except that one thing I notice, the browser sync is disabled. I am guessing this might be the problem.

To give you more picture, I cannot even run the movie example. When I clicked on it, the cypher query shows up on the browser query section. When I run it, the query vanishes just like when the query is executed, but this time, nothing is executed. I created a new node, but the node is not stored, even though no error message shows up.

Actually, after checking the browser console, I received an error message

Uncaught TypeError: You provided an invalid object where a stream was expected. You can provide an Observable, Promise, Array, or Iterable.
at Object.r [as subscribeToResult] (vendor-897c4a0edc066f73fbd8.js:1)
at t.error (vendor-897c4a0edc066f73fbd8.js:1)
at vendor-897c4a0edc066f73fbd8.js:1

Can you share how you isntalled neo4j before and now
and also your neo4j.conf and the changes you made there.

Install Process:

  1. Since I want to have neo4j in a server, so I did


  1. then I unpack it

sudo tar -xfz artifact.php?name=neo4j-community-3.4.8-unix.tar.gz

  1. Delete data so that it can access the previous data

sudo rm -rf data

  1. change my data directory through symlink

sudo ln -s / /data

  1. Configure Configuration in neo4j.conf:
# Paths of directories in the installation.<symlink data dir>

dbms.memory.heap.max_size=5000m #server ip

# Bolt connector

# HTTP Connector. There must be exactly one HTTP connector.

# To enable HTTP logging, uncomment this line

# Enable a remote shell server which Neo4j Shell clients can log in to.
# The network interface IP the shell will listen on (use for all interfaces).
# The port the shell will listen on, default is 1337.

This is the changes I made, and I don't change anything anymore... The security is just for me to try first before I put the password

Does it work if you don't do the path config changes?

There is a hierarchy of directories under data which should not be destroyed

find data -type d

The other data base has all the hierarchy directories because it was from the data directory in Neo4j 3.3.

And to answer your question, no.

Well, I re downloaded and re-install neo4j 3.4 with the hope that it will fix by itself. Now I have another issue, that the certificate directory is not there. My assumption is that it was genreated automatically, but it is not the case (I re-download and re-install 5 times to be exact now and no certificate directory from the community edition).

This is the log error:

2018-10-10 03:47:36.224+0000 INFO  ======== Neo4j 3.4.8 ========                                                                                                                                                  
2018-10-10 03:47:36.264+0000 INFO  Starting...                                                                                                                                                                    
2018-10-10 03:47:38.281+0000 ERROR Failed to start Neo4j: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabase@58ce9668' was successfully initialized, but failed to start. Pleas
e see the attached cause exception "/opt/neo4j-community-3.4.8/certificates/neo4j.cert (No such file or directory)". Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabase@58ce966
8' was successfully initialized, but failed to start. Please see the attached cause exception "/opt/neo4j-community-3.4.8/certificates/neo4j.cert (No such file or directory)".                                   
org.neo4j.server.ServerStartupException: Starting Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabase@58ce9668' was successfully initialized, but failed to start. Please see the attache
d cause exception "/opt/neo4j-community-3.4.8/certificates/neo4j.cert (No such file or directory)".                                                                                                               
        at org.neo4j.server.exception.ServerStartupErrors.translateToServerStartupError(                                                                                              
        at org.neo4j.server.AbstractNeoServer.start(                                                                                                                                   
        at org.neo4j.server.ServerBootstrapper.start(                                                                                                                                 
        at org.neo4j.server.ServerBootstrapper.start(                                                                                                                                  
        at org.neo4j.server.CommunityEntryPoint.main(                                                                                                                                 
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.server.database.LifecycleManagingDatabase@58ce9668' was successfully initialized, but failed to start. Please see the attached caus
e exception "/opt/neo4j-community-3.4.8/certificates/neo4j.cert (No such file or directory)".                                                                                                                     
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(                                                                                                                   
        at org.neo4j.kernel.lifecycle.LifeSupport.start(                                                                                                                                     
        at org.neo4j.server.AbstractNeoServer.start(
        ... 3 more
Caused by: java.lang.RuntimeException: Error starting org.neo4j.kernel.impl.factory.GraphDatabaseFacadeFactory, /opt/neo4j-community-3.4.8/data/databases/graph.db
        at org.neo4j.kernel.impl.factory.GraphDatabaseFacadeFactory.initFacade(
        at org.neo4j.kernel.impl.factory.GraphDatabaseFacadeFactory.newFacade(
        at org.neo4j.server.CommunityNeoServer.lambda$static$0(
        at org.neo4j.server.database.LifecycleManagingDatabase.start(
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(
        ... 5 more
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.kernel.extension.KernelExtensions@19c65cdc' failed to initialize. Please see the attached cause exception "/opt/neo4j-community-3.4.8/certificates/neo4j.cert (No such file or directory)".
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.init(
        at org.neo4j.kernel.lifecycle.LifeSupport.init(
        at org.neo4j.kernel.lifecycle.LifeSupport.start(
        at org.neo4j.kernel.impl.factory.GraphDatabaseFacadeFactory.initFacade(
        ... 9 more
Caused by: java.lang.RuntimeException: Failed to initialize SSL encryption support, which is required to start this connector. Error was: Failed to generate private key and certificate
        at org.neo4j.bolt.BoltKernelExtension.createSslContext(
        at org.neo4j.bolt.BoltKernelExtension.lambda$createConnectors$0(
        at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(
        at org.neo4j.bolt.BoltKernelExtension.createConnectors(
        at org.neo4j.bolt.BoltKernelExtension.newInstance(
        at org.neo4j.bolt.BoltKernelExtension.newInstance(
        at org.neo4j.kernel.extension.KernelExtensions.newInstance(
        at org.neo4j.kernel.extension.KernelExtensions.init(
        at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.init(
        ... 12 more
Caused by: java.lang.RuntimeException: Failed to generate private key and certificate
        at org.neo4j.kernel.configuration.ssl.SslPolicyLoader.loadOrCreateLegacyPolicy(
        at org.neo4j.kernel.configuration.ssl.SslPolicyLoader.getOrCreateLegacyPolicy(
        at org.neo4j.kernel.configuration.ssl.SslPolicyLoader.getPolicy(
        at org.neo4j.bolt.BoltKernelExtension.createSslContext(
        ... 27 more
Caused by: /opt/neo4j-community-3.4.8/certificates/neo4j.cert (No such file or directory)
        at Method)
        at org.neo4j.ssl.PkiUtils.writePem(
        at org.neo4j.ssl.PkiUtils.createSelfSignedCertificate(
        at org.neo4j.kernel.configuration.ssl.SslPolicyLoader.loadOrCreateLegacyPolicy(
        ... 30 more
2018-10-10 03:47:38.283+0000 INFO  Neo4j Server shutdown initiated by request
Cleaning up partially generated self-signed certificate...```

I did not change anything on the config other than: #server ip

Just so that I can run it. I did not change the data dir this time

How did you install it? When I untar and start neo4j-community-3.4.8-unix.tar.gz it has the two certificates in the directory.

Did you try to run it manually with bin/neo4j console to see if it starts up then?

Are the certs there on your file system? What about access permissions? E.g. for the user running the server?

Exactly how I wrote above. And the way I run it is by going into the directory, and run

bin/neo4j start
I don't think I have any problem with permission, my only confusion is when I untar it, I don't have the cert directory.


I have the same the error Darius described.
And I use the docker image provided by neo: Docker
If I rollback to version 3.4.7 it works again.