LOAD CSV & Google Sheets

I came across this article by @rvanbruggen about using LOAD CSV. As stated in the blog, it in order for this to work, the spreadsheet needs to be accessible by anyone on the internet because Neo4j doesn't know how to handle the authentication.

My question is: has there been any improvements or updates that would permit connecting to a private Google Sheet?

I haven't had much luck yet navigating around the issue I get when attempting to import a google sheet directly. I get the following error:

Neo.DatabaseError.General.UnknownError: At https://docs.google.com/spreadsheets/d/1J5DbP_5g_bSwx903pg_TuJYOBjqWIycDv0A5JM2_TIY/export?format=csv&id=1J5DbP_5g_bSwx903pg_TuJYOBjqWIycDv0A5JM2_TIY&gid=1185833437 @ position 30192 -  there's a field starting with a quote and whereas it ends that quote there seems to be characters in that field after that ending quote. That isn't supported. This is what I read: '>
<div  class="c'

I am not sure to what exactly this is referring.

1 Like

I am even attempting to use the Sandbox with Google Sheets but the first page seems to fail in loading the initial command/query to start the tutorial. There is not "play" button to use the pre-populated command.

Hazaa! Looks like I had my browser blocking cookies preventing me from importing into the database. Additionally, I had failed to adequately set my sheet to public so that I could access it for the LOAD CSV command.

Thanks to @ryan.boyd for helping me figure it out!

I thought I had it figured out, but I seem to be running into some inconsistencies. Is anyone using Google Sheets with LOAD CSV regularly that can help me out?

So I was able to figure it out after chatting with someone on the slack channel=:

  1. I was forgetting to include fieldterminator
  2. I had failed to set the file public

Problem solved!

@mckenzma @ryan.boyd

I am trying to LOAD a Google Drive csv in to the sandbox, and am getting the same error.

Tried adding sandbox to trusted sites, making the file public, including fieldterminator as mentioned in this thread, but no luck.

I am still getting the same error as mckenzma.

Can you please help?

Can you share the code you are using and a screen shot of the error message?