Load CSV completed successfully but data is not showing on UI

I have loaded following files from UI using "LOAD CSV WITH HEADERS FROM 'file:///movie.csv' as line return line" Load command executed successfully. but match(n) return n is showing 0 record on UI.

LOAD CSV WITH HEADERS FROM 'file:///actors.csv' as line return line
keanu,"Keanu Reeves",Actor
laurence,"Laurence Fishburne",Actor
carrieanne,"Carrie-Anne Moss",Actor

LOAD CSV WITH HEADERS FROM 'file:///movie.csv' as line return line
tt0133093,"The Matrix",1999,Movie
tt0234215,"The Matrix Reloaded",2003,Sequel
tt0242653,"The Matrix Revolutions",2003,Movie

LOAD CSV WITH HEADERS FROM 'file:///roles.csv' as line return line

Please someone help me here why match(n) return n is showing 0 records.


The CSV's are in neo4j-admin import format. For LOAD CSV command you need to use cypher.

Please follow these instructions to load the data

This document gives commands to load the data also.

I have also tried to load data with neo4j-admin import command. Command completed successfully. But after that I ran MATCH (n) RETURN count(n) as count cypher command but this command return 0 records.

Can you please list down instructions you have tried and in which directories?

There is a subtle difference to LOAD CSV and neo4j-admin import.

neo4j-admin import creates a database and it can be done only for the first time. You cannot import data into existing database.

LOAD CSV on the other hand works on a database that is running. It's more like batch query execution and is bounded by transactions.

If you want to play with LOAD CSV commands you can try these things.

Follow the tutorial at:

You can also do this in browser after you start the database. Once the database is up and running and you login using browser in the query field you can type

:play movies

This will bring up a tab below the query panel a carousel with queries with guided instructions to load the data and query the data.

This page explains both LOAD CSV and neo4j-admin import.