Issue in integrating neo4j to elasticsearch

Hi All,

As I was tried to push data to Elasticsearch by using the below neo4j-Elasticsearch integration,

I am currently using neo4j 3.5.6 and Elasticsearch 6.3.2 versions. Below is my neo4j.conf which i followed the example in the link


After restarting the neo4j I am getting below error in logs,

2019-06-24 12:25:15.113+0000 INFO  ======== Neo4j 3.5.6 ========
2019-06-24 12:25:15.125+0000 INFO  Starting...
2019-06-24 12:25:16.068+0000 ERROR ElasticSearch Integration: syntax error in index_spec
2019-06-24 12:25:16.953+0000 INFO  GraphAware Runtime disabled.
2019-06-24 12:25:27.264+0000 INFO  Bolt enabled on localhost:7688.
2019-06-24 12:25:29.124+0000 INFO  Started.
2019-06-24 12:25:30.772+0000 INFO  Remote interface available at http://localhost:7475

Correct me if I am doing anything wronig in the setup and let me know your thoughts.

Ganeshbabu R

Can you create a GitHub issue please.

Thank you

Yes I have created the github issue,

Ganeshbabu R

Are you sure properties has PascalCase not snake_case?


If not, it should be?


Hi @ri8ika,

I tried with snake_case or even without any properties I am still getting the same error,

ERROR ElasticSearch Integration: syntax error in index_spec

Ganeshbabu R

You should be sure what properties are defined in Software and Hardware.

Yes right I am doing this integration for the first time so I am trying with two nodes with single property

can you try to use index names that have more than one character?