Is this an APOC import bug?

For this example:



Then execute this per documentation:
CALL apoc.import.csv([{fileName: 'file:/persons.csv', labels: ['Person']}], [], {})

This reports this error:
Failed to invoke procedure apoc.import.csv: Caused by: java.lang.IllegalStateException: No match found

Is this a bug? Or some syntax error in the documentation? The syntax sees right based on the function signature.

If you are using Neo4j version 4.0 and above do the following:

Open a text editor and copy these in that file:


Save this file as apoc.conf.

Place this file in data/dbms/dbms...../conf folder. neo4j.conf file also resides in this folder.

I have this two entries configured in conf/neo4j.conf and it seems working. It is working for other APOC procedures. For example, if I change the name to ":ID", it works fine. I am afraid the APOC import needs each entry to have a least an ID property. I tried other examples, it works.Also, I tried both 4.04 and 4.13 version, under the data/directory, there are only:

databases transactions

No 'dbms' directory.