IP Address reset after restarting EC2 instance - now connection times out

I'm running Neo4J 3.5.14 on a Linux EC2 instance.

I needed to increase the power of my instance, so I stopped it, altered it, and started it up again. This changed my IP address.

Now the page just times out when I try to access the database browser at the default advertised address and GraphQL no longer connects. I can access the neo4j browser by going directly to my new IP address (, though it is an insecure connection.

I can access the database using cypher-shell if I use the new IP address as the address cypher-shell -a If I try to use the URL as the address with cypher-shell, i.e. cypher-shell -a neo4j.myurl.net I get the following error:

connection timed out: neo4j.myurl.net/

The is the original IP of my EC2 instance before I restarted it! I can't figure out where neo4j is storing that IP address. I've gone through the neo4j.conf file about a hundred times and I'm absolutely sure that the IP address doesn't appear there and never did.

I tried to remedy the problem by explicitly setting my new IP address as the dmbs listen addresses (dbms.connectors.default_listen_address= First I tried changing all of the options to my new IP, then I tried just the dbms.connector.bolt.listen_address. The only thing that happened was an endless loop of Neo4J restarting itself every second.

This all seems like really bizarre behavior and I have no idea what to do. Since I was getting an insecure connection error when i go directly to the neo4j browser at, I even tried a forced renewal of my SSL certificates. No change.

There are so many variables here I don't know where to start, except maybe two questions

  • did you check the dns resolution for neo4j.myurl.net is showing the new ip address?

If access by IP works and by dns name does not, this shouldn't be applicable but most of my AWS issues involve the following

  • double check that the traffic between client and server is allowed (e.g. firewall and subnet settings, etc)

Aha, that was it. My DNS was not resolving to the new IP address. Not actually a Neo problem at all. Thanks for giving me the starting point!