Installed Neo4j enterprise on Ubuntu, but cannot access the browser

When I try to access the Neo4j browser, I get a 502 Bad Gateway error from Nginx.

I'm running a Digital Ocean Ubuntu 16.04.2 x64 server, and I followed the instructions here to install Neo4J enterprise.

These are the steps I took:

echo "deb jessie-backports main" | sudo tee -a /etc/apt/sources.list.d/jessie-backports.list
sudo apt-get update
sudo apt-get -t jessie-backports install ca-certificates-java
sudo apt-get install neo4j-enterprise=1:3.4.6

I then did:

systemctl enable neo4j

I tried editing /etc/neo4j/neo4j.conf, modifying the following lines:


When I visit https://my.ip.address/browser, I get a 502 Bad Gateway error. If I visit https://my.ip.address:7473, I get a timeout. I'm not sure what I'm doing wrong. Any help would be appreciated.

comment those two, then uncoment and config next two lines:

I noticed if "Advertising address" is not configured properly, you won't be able to open WEB interface. Also, don't forget to check Firewall.

Have you tried with http protocol ?

Besides, you may config for your IP

By the way, If you are using Ubuntu, it's better for installing Neo4j via Docker. I think it's more convenient :slight_smile:

you can also put in
for the listen address then it will listen to all interfaces.

1 Like

Thanks all for the help. @harvey_nguyen I went with Docker as you suggested. Works like a charm! Thanks for that.

1 Like