Install GRAPH DATA SCIENCE in neo4j version 4

we are trying to make " [GRAPH DATA SCIENCE]" work with neo4j stand alone server 4.0.1 by copying
"neo4j-graph-data-science-1.1.0-alpha02-standalone.jar" in /var/lib/neo4j/plugins and also by setting*.

In the browser RETURN gds.version() returns"1.1.0-alpha02" but Return gds.list() is throwing the following error
Unknown function 'gds.list' (line 1, column 8 (offset: 7))
"RETURN gds.list()"

Am i missing some thing here


1 Like

GDS Library is not yet moved to 4.0. Use Neo4j 3.5 instead.

1 Like


I am also facing the same issue. Neo4j version is 3.5.17. Can you tell if there is something we are missing

Make sure you have the jar file in /plugins - not the zip file.

1 Like

It's CALL gds.list() and RETURN gds.version().

For step by step installation instructions see: Installation - Neo4j Graph Data Science

1 Like

I have the jar file placed at /plugins.. Have cross checked it.. Still not working

please paste latest startup sequence of your logs/debug.log.

Hi... Was this resolved using 3.5.17 ? Im stuck on the 4.0.3 and wondering if down grading and reloading all my data is worth the effort or. to simply wait till the end of the month for the library release

Is it coming soon? :slight_smile:

Define "soon" ;-) ...

Hmm lets say in 2-3 months?

I guess that should work.

GDS 1.2 preview is compatible with Neo4j 4.x .

no it wasn't.. Also I couldn't find anything about gds in my logs..

@ami.ta @guarav.malhotra - please download GDS 1.2 preview release from the Neo4j download center, and place it in your plugins folder. That release is compatible with Neo4j 4.0.

1 Like

I downloaded GDS 1.2 (neo4j-graph-data-science-1.2.0-alpha01-standalone), unzipped it and placed the jar in the right directory (using the 'open folder -> Plugins' button in Neo4j Desktop)

I added in my settings:"apoc.,gds.""apoc.,gds."

But when I start the DB, I get:
2020-05-04 20:20:10.321+0000 WARN The '' setting is overridden. Setting value changed from '"apoc.,gds."' to 'apoc.*'.

And GDS does not work. Any hint, please?

Actually, I got it working using the pre-release version of neo4j Desktop.

But now I am trying to make it work from a docker image:

FROM neo4j:4.0.3-enterprise


ENV NEO4J_dbms_security_procedures_unrestricted="apoc.*,gds.*"

ENV NEO4J_dbms_security_procedures_whitelist="apoc.*,gds.*"

ENV NEO4J_apoc_import_file_enabled="true"

ENV NEO4J_apoc_export_file_enabled="true"


ENV NEO4J_dbms_default__listen__address=""

ENV NEO4J_dbms_allow__upgrade="true"

COPY neo4j/plugins/ /var/lib/neo4j/plugins

EXPOSE 7474 7473 7687

CMD ["neo4j"]

But the jar is not recognized...

Neo4j failed: Component 'org.neo4j.server.database.LifecycleManagingDatabaseService@6b70d1fb' was successfully initialized, but failed to start. Please see the attached cause exception "Some jar procedure files are invalid, see log for details."

Any idea? :slight_smile:

Hello, I'm actually facing the same problem. So I was wondering where we can find the jar files instead of the zip ones ? I don't find it anywhere and gds still not working. Could you help please ? Thanks :)

We post jar files to our github: Release Graph Data Science 1.8.3 · neo4j/graph-data-science · GitHub