Install failure on Ubuntu 18.04

I already have openJDK 11, as seen below:

update-alternatives --config java
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection    Path                                            Priority   Status
  0            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      auto mode
* 1            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      0         manual mode
  2            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode

Press <enter> to keep the current choice[*], or type selection number: 1

Now I check the Java version:

tf-docker /data1/congmin/apps/neo4j-4.0.4 > java --version
openjdk 11.0.11 2021-04-20
OpenJDK Runtime Environment (build 11.0.11+9-Ubuntu-0ubuntu2.18.04)
OpenJDK 64-Bit Server VM (build 11.0.11+9-Ubuntu-0ubuntu2.18.04, mixed mode, sharing)

Java 11, which seems right. Now start neo4j:

tf-docker /data1/congmin/apps/neo4j-4.0.4 > bin/neo4j start

ERROR! Neo4j cannot be started using java version 1.8.0_275. 
* Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j.
* Please see for Neo4j installation instructions.

The way I installed Neo4j on Ubuntu is just untar the .tar neo4j package and execute "neo4j start". I also tried the following after I did some repository configuration:

apt install neo4j

This installation was successful too, but when I run it I got the same error message, complaining Java version.