Importing data directory Windows 10 desktop

New to neo4j here. I'm running the Windows 10 desktop application, version 1.2.5. A collaborator has sent me a neo4j database directory as what appears to be a copy of the directory itself. The 'data' directory contains two subdirectories, 'databases' and 'dbms'. Inside 'databases' is the 'graph.db' directory which contains a number of files with extensions such as .db, .id, .labels, etc.

So I'm trying to figure out how to import this data into neo4j desktop. I've tried a naive approach of creating a graph under a new project, then moving the 'data' folder to the database directory that gets created (before starting the database). That doesn't seem to be working. When I try to start up the database, I get a popup 'Password has been changed' and when I try to enter the password I used when creating the graph via the desktop I get 'Failed - not a valid password.'

Not sure how to proceed. Is there a different way I should be importing the data? Is there potentially a password already in the database that was shared with me that I need to track down?

I ran into similar issue when trying to solve the upgrade between v3.5 to v4.0. Even though you didn't mention you're attempting the upgrade, in this video they offer a similar steps that you're describing of copying the graph.db folder into a new instance. Give the steps in this video a try and see if that solves things for you #GraphCast: Migrating from Neo4j 3.5 to 4.0

I'm using Neo4J Desktop 1.2.5 in Windows 10, whereas the example in the blog post was on a Mac with command line interface. It's not clear to me how to translate the actions there to the Windows desktop environment