I cannot install neo4j-community-3.5.12 server by typing command install-service in cmd


I have Windows 7 x64, java version 1.8.0_201 and JDK 11. After entering command neo4j "install-service" or "neo4j console" the following message is displayed: " 'Powershell' is not recognized as an internal or external command, operable program or batch file."
It looks like this:

In the environmental variable PATH I have added: %SystemRoot%\System32\Wbem;
C:\Program Files\Java\jdk1.8.0_201\bin

I have spent a long time to solve this problem, but it is still the same. Could you help me with it? Maybe someone had a similar problem ?

Hi, Karolkojro,

I met the same situation. Finally, I solved this issues.

  1. Setup new environmental variable. NEO4J_HOME='your root path of neo4j-community'.
  2. Add the path in environmental variable.
    After that, you may have a try.

If there are some new errors occur related to 'Import-Module', you could update the PSScriptRoot with '%your path%\neo4j\bin' in Neo4j-Management.psd1 file.